Bug 89280 - REGRESSION (r120246): <video> progress control doesn't draw handle on Mac
Summary: REGRESSION (r120246): <video> progress control doesn't draw handle on Mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Blocker
Assignee: Silvia Pfeiffer
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2012-06-16 02:24 PDT by Tim Horton
Modified: 2012-06-18 16:02 PDT (History)
10 users (show)

See Also:


Attachments
before (87.27 KB, image/png)
2012-06-16 02:24 PDT, Tim Horton
no flags Details
after (88.15 KB, image/png)
2012-06-16 02:24 PDT, Tim Horton
no flags Details
patch for review (1.95 KB, patch)
2012-06-16 16:12 PDT, Silvia Pfeiffer
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Horton 2012-06-16 02:24:02 PDT
See attached screenshots. The little grabby handle on <video> on Mac broke in http://trac.webkit.org/changeset/120246. Possible that we should have investigated instead of rebaselining the tests, unfortunate that we don't have pixel tests in a good state.
Comment 1 Tim Horton 2012-06-16 02:24:29 PDT
Created attachment 147959 [details]
before
Comment 2 Tim Horton 2012-06-16 02:24:41 PDT
Created attachment 147960 [details]
after
Comment 3 Radar WebKit Bug Importer 2012-06-16 02:26:56 PDT
<rdar://problem/11683093>
Comment 4 Silvia Pfeiffer 2012-06-16 03:15:25 PDT
Can you check if the volume thumb is still there?

It may be related to the change of media slider thumbs to a shadowPseudoId of "webkit-media-slider-thumb" from "webkit-slider-thumb".
Comment 5 Tim Horton 2012-06-16 03:16:56 PDT
(In reply to comment #4)
> Can you check if the volume thumb is still there?

The volume thumb is also missing.

> It may be related to the change of media slider thumbs to a shadowPseudoId of "webkit-media-slider-thumb" from "webkit-slider-thumb".
Comment 6 Silvia Pfeiffer 2012-06-16 03:19:44 PDT
OK, since my build doesn't replicate the bug, could you check whether changing this rule in WebCor/css/html.cc to add  "input[type="range"]::-webkit-media-slider-thumb" might fix it?

input[type="range"]::-webkit-slider-thumb {
    -webkit-appearance: sliderthumb-horizontal;
    -webkit-box-sizing: border-box;
    display: block;
    position: relative;
}
Comment 7 Silvia Pfeiffer 2012-06-16 03:21:13 PDT
If that works, also add input[type="range"]::-webkit-media-slider-container to the rule of input[type="range"]::-webkit-slider-container .
Comment 8 Tim Horton 2012-06-16 09:52:46 PDT
(In reply to comment #7)
> If that works, also add input[type="range"]::-webkit-media-slider-container to the rule of input[type="range"]::-webkit-slider-container .

Works great, will you land it? I'm not 100% sure what I'm changing, so it's hard to write a changelog, nor am I sure that was the final goal versus just a test.
Comment 9 Silvia Pfeiffer 2012-06-16 15:20:06 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > If that works, also add input[type="range"]::-webkit-media-slider-container to the rule of input[type="range"]::-webkit-slider-container .
> 
> Works great, will you land it? I'm not 100% sure what I'm changing, so it's hard to write a changelog, nor am I sure that was the final goal versus just a test.

Can do. Give me an hour or so.
Comment 10 Silvia Pfeiffer 2012-06-16 16:12:42 PDT
Created attachment 147991 [details]
patch for review
Comment 11 WebKit Review Bot 2012-06-18 08:04:23 PDT
Comment on attachment 147991 [details]
patch for review

Clearing flags on attachment: 147991

Committed r120596: <http://trac.webkit.org/changeset/120596>
Comment 12 WebKit Review Bot 2012-06-18 08:04:29 PDT
All reviewed patches have been landed.  Closing bug.
Comment 13 Simon Fraser (smfr) 2012-06-18 11:14:49 PDT
Looks like this cause media/controls-after-reload.html to fail:
http://build.webkit.org/results/Apple%20Lion%20Release%20WK1%20(Tests)/r120608%20(242)/media/controls-after-reload-pretty-diff.html
Comment 14 Tim Horton 2012-06-18 11:26:11 PDT
(In reply to comment #13)
> Looks like this cause media/controls-after-reload.html to fail:
> http://build.webkit.org/results/Apple%20Lion%20Release%20WK1%20(Tests)/r120608%20(242)/media/controls-after-reload-pretty-diff.html

Probably the rebaseline in http://trac.webkit.org/changeset/120345 was wrong.
Comment 15 Silvia Pfeiffer 2012-06-18 16:02:43 PDT
If the controls look ok, yes, I would assume the rebaseline should be redone.