Bug 89073 - Modify event re-targeting algorithm so that we can tell which distributed node is clicked.
Summary: Modify event re-targeting algorithm so that we can tell which distributed nod...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Hayato Ito
URL:
Keywords:
: 89708 (view as bug list)
Depends on: 89172 89180 89407 89479 89703 89729
Blocks: 59805 89708
  Show dependency treegraph
 
Reported: 2012-06-14 01:32 PDT by Hayato Ito
Modified: 2012-06-22 11:10 PDT (History)
7 users (show)

See Also:


Attachments
WIP. concept of a new re-targeting algorithm (15.11 KB, patch)
2012-06-14 01:55 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
target can now be a distributed node (16.18 KB, patch)
2012-06-19 14:59 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
minor update on changelog (15.97 KB, patch)
2012-06-21 09:46 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
minor update on changelog (15.97 KB, patch)
2012-06-21 09:49 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
Patch for landing (15.97 KB, patch)
2012-06-21 10:00 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
Patch for landing (15.98 KB, patch)
2012-06-21 10:02 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff
Patch for landing (16.09 KB, patch)
2012-06-22 09:55 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hayato Ito 2012-06-14 01:32:18 PDT
Please see the going discussion on the spec side:
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17090

We have to adopt a new algorithm once we agree on the new behavior of event re-targeting on the Shadow DOM spec.
Comment 1 Hayato Ito 2012-06-14 01:55:47 PDT
Created attachment 147520 [details]
WIP. concept of a new re-targeting algorithm
Comment 2 Dimitri Glazkov (Google) 2012-06-14 09:26:52 PDT
Comment on attachment 147520 [details]
WIP. concept of a new re-targeting algorithm

I haven't dug into this deeply, but from the first glance, this looks great!
Comment 3 Hayato Ito 2012-06-19 14:59:32 PDT
Created attachment 148436 [details]
target can now be a distributed node
Comment 4 Hayato Ito 2012-06-21 09:46:40 PDT
Created attachment 148820 [details]
minor update on changelog
Comment 5 Hayato Ito 2012-06-21 09:49:58 PDT
Created attachment 148821 [details]
minor update on changelog
Comment 6 Hayato Ito 2012-06-21 09:57:03 PDT
Since it got r+ for https://bugs.webkit.org/attachment.cgi?id=148820&action=review, let me land this manually.
Comment 7 Hayato Ito 2012-06-21 10:00:10 PDT
Created attachment 148825 [details]
Patch for landing
Comment 8 Hayato Ito 2012-06-21 10:02:44 PDT
Created attachment 148826 [details]
Patch for landing
Comment 9 WebKit Review Bot 2012-06-21 11:05:44 PDT
Comment on attachment 148826 [details]
Patch for landing

Clearing flags on attachment: 148826

Committed r120945: <http://trac.webkit.org/changeset/120945>
Comment 10 WebKit Review Bot 2012-06-21 11:05:51 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 WebKit Review Bot 2012-06-21 16:05:52 PDT
Re-opened since this is blocked by 89703
Comment 12 Kenneth Russell 2012-06-21 16:56:41 PDT
*** Bug 89708 has been marked as a duplicate of this bug. ***
Comment 13 Hayato Ito 2012-06-21 17:09:13 PDT
I've investigated the crash of editing/shadow/breaking-editing-boundaries.html.

It seems this re-targeting patch is innocent. This patch just revealed a bogus DOM structure that was caused in editing/shadow/breaking-editing-boundaries.html.

So it seems an editing bug. Let me investigate further.
Comment 14 Hayato Ito 2012-06-21 17:22:26 PDT
It seems parentTreeScope() returns an unexpected node.
And I found this bug. https://bugs.webkit.org/show_bug.cgi?id=89172
That's the root cause.

(In reply to comment #13)
> I've investigated the crash of editing/shadow/breaking-editing-boundaries.html.
> 
> It seems this re-targeting patch is innocent. This patch just revealed a bogus DOM structure that was caused in editing/shadow/breaking-editing-boundaries.html.
> 
> So it seems an editing bug. Let me investigate further.
Comment 15 Hayato Ito 2012-06-21 17:27:47 PDT
I'll re-land this patch once bug 89172 is resolved.

(In reply to comment #14)
> It seems parentTreeScope() returns an unexpected node.
> And I found this bug. https://bugs.webkit.org/show_bug.cgi?id=89172
> That's the root cause.
> 
> (In reply to comment #13)
> > I've investigated the crash of editing/shadow/breaking-editing-boundaries.html.
> > 
> > It seems this re-targeting patch is innocent. This patch just revealed a bogus DOM structure that was caused in editing/shadow/breaking-editing-boundaries.html.
> > 
> > So it seems an editing bug. Let me investigate further.
Comment 16 Hayato Ito 2012-06-22 09:55:47 PDT
Created attachment 149045 [details]
Patch for landing
Comment 17 Hayato Ito 2012-06-22 09:57:21 PDT
Let me re-land this patch since bug 89172 was resolved and confirmed that editing/shadow/breaking-editing-boundaries.html does not crash anymore.
Comment 18 WebKit Review Bot 2012-06-22 11:10:21 PDT
Comment on attachment 149045 [details]
Patch for landing

Clearing flags on attachment: 149045

Committed r121040: <http://trac.webkit.org/changeset/121040>
Comment 19 WebKit Review Bot 2012-06-22 11:10:41 PDT
All reviewed patches have been landed.  Closing bug.