Bug 88860 - Refactor InputType::receiveDroppedFiles to take DragData
Summary: Refactor InputType::receiveDroppedFiles to take DragData
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kinuko Yasuda
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-12 04:42 PDT by Kinuko Yasuda
Modified: 2012-06-12 08:34 PDT (History)
1 user (show)

See Also:


Attachments
Patch (7.34 KB, patch)
2012-06-12 04:45 PDT, Kinuko Yasuda
tkent: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kinuko Yasuda 2012-06-12 04:42:06 PDT
This issue is splitted from bug 88293.

Refactor InputType::receiveDroppedFiles to take DragData and move the code extracting files from DragData into FileInputType.cpp, to make it easier to extract more data from DragData for <input type=file> (like bug 88293 for directory drag-and-drop).
Comment 1 Kinuko Yasuda 2012-06-12 04:45:48 PDT
Created attachment 147058 [details]
Patch
Comment 2 Kent Tamura 2012-06-12 05:04:36 PDT
Comment on attachment 147058 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=147058&action=review

> Source/WebCore/html/FileInputType.h:67
> -    virtual void receiveDroppedFiles(const Vector<String>&) OVERRIDE;
> +    virtual bool receiveDroppedFiles(const DragData*) OVERRIDE;

had better add a comment explaining what is the return value.
Comment 3 Kent Tamura 2012-06-12 05:05:29 PDT
(In reply to comment #2)
> (From update of attachment 147058 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=147058&action=review
> 
> > Source/WebCore/html/FileInputType.h:67
> > -    virtual void receiveDroppedFiles(const Vector<String>&) OVERRIDE;
> > +    virtual bool receiveDroppedFiles(const DragData*) OVERRIDE;
> 
> had better add a comment explaining what is the return value.

oh, not here.   we had better add it to HTMLInputElement.h and InputType.h.
Comment 4 Kinuko Yasuda 2012-06-12 05:06:51 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > (From update of attachment 147058 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=147058&action=review
> > 
> > > Source/WebCore/html/FileInputType.h:67
> > > -    virtual void receiveDroppedFiles(const Vector<String>&) OVERRIDE;
> > > +    virtual bool receiveDroppedFiles(const DragData*) OVERRIDE;
> > 
> > had better add a comment explaining what is the return value.
> 
> oh, not here.   we had better add it to HTMLInputElement.h and InputType.h.

Will do.  Thanks!
Comment 5 Kinuko Yasuda 2012-06-12 08:34:45 PDT
Committed r120081: <http://trac.webkit.org/changeset/120081>