Bug 87750 - [Qt][WK2] REGRESSION(r118761): It made 2 tests crash
Summary: [Qt][WK2] REGRESSION(r118761): It made 2 tests crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Critical
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 79668 87675
  Show dependency treegraph
 
Reported: 2012-05-29 08:55 PDT by Csaba Osztrogonác
Modified: 2012-10-09 00:07 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-05-29 08:55:21 PDT
Crash log for fast/backgrounds/opacity-on-document-element.html:
-----------------------------------------------------------------
crash log for WebProcess (pid <unknown>):
STDOUT: <empty>
STDERR: 1   0x7fdc8e0adc18 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libWTRInjectedBundle.so(+0x35c18) [0x7fdc8e0adc18]
STDERR: 2   0x7fdcda74d420 /lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7fdcda74d420]
STDERR: 3   0x7fdcdcf484d6 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WTF::Vector<WebCore::Attribute, 0ul>::shrink(unsigned long)+0x46) [0x7fdcdcf484d6]
STDERR: 4   0x7fdcdcf493ab /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::ElementAttributeData::~ElementAttributeData()+0x1b) [0x7fdcdcf493ab]
STDERR: 5   0x7fdcdcf4a227 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::Element::~Element()+0x77) [0x7fdcdcf4a227]
STDERR: 6   0x7fdcdd0a76c1 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::HTMLDivElement::~HTMLDivElement()+0x21) [0x7fdcdd0a76c1]
STDERR: 7   0x7fdcdcdab8e2 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::JSNodeOwner::finalize(JSC::Handle<JSC::Unknown>, void*)+0x122) [0x7fdcdcdab8e2]
STDERR: 8   0x7fdcddde3e81 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::WeakBlock::sweep()+0x81) [0x7fdcddde3e81]
STDERR: 9   0x7fdcddde3b15 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::WeakSet::sweep()+0x65) [0x7fdcddde3b15]
STDERR: 10  0x7fdcdddedd8b /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::MarkedSpace::sweepWeakSets()+0x7b) [0x7fdcdddedd8b]
STDERR: 11  0x7fdcddde77b5 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::Heap::collect(JSC::Heap::SweepToggle)+0x75) [0x7fdcddde77b5]
STDERR: 12  0x7fdcdcd4adfa /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(+0xeb4dfa) [0x7fdcdcd4adfa]
STDERR: 13  0x7fdcdd3d6132 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::ThreadTimers::sharedTimerFiredInternal()+0xa2) [0x7fdcdd3d6132]
STDERR: 14  0x7fdcdb20b819 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QObject::event(QEvent*)+0x69) [0x7fdcdb20b819]
STDERR: 15  0x7fdcdb7acbf4 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0xb4) [0x7fdcdb7acbf4]
STDERR: 16  0x7fdcdb7afc5d /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplication::notify(QObject*, QEvent*)+0x3ad) [0x7fdcdb7afc5d]
STDERR: 17  0x7fdcdb1e4b44 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x84) [0x7fdcdb1e4b44]
STDERR: 18  0x7fdcdb22b1dc /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QTimerInfoList::activateTimers()+0x47c) [0x7fdcdb22b1dc]
STDERR: 19  0x7fdcdb22ba5d /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(+0x256a5d) [0x7fdcdb22ba5d]
STDERR: 20  0x7fdcd5c83a5d /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x1dd) [0x7fdcd5c83a5d]
STDERR: 21  0x7fdcd5c84258 /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x45258) [0x7fdcd5c84258]
STDERR: 22  0x7fdcd5c84429 /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x69) [0x7fdcd5c84429]
STDERR: 23  0x7fdcdb22c224 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x64) [0x7fdcdb22c224]
STDERR: 24  0x7fdcdb1e3a7b /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0xdb) [0x7fdcdb1e3a7b]
STDERR: 25  0x7fdcdb1e73b0 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplication::exec()+0x80) [0x7fdcdb1e73b0]
STDERR: 26  0x7fdcdd5c5e6c /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::RunLoop::run()+0x5c) [0x7fdcdd5c5e6c]
STDERR: 27  0x7fdcdcc8ffdd /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebKit::WebProcessMainQt(QGuiApplication*)+0x37d) [0x7fdcdcc8ffdd]
STDERR: 28  0x400b19 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/bin/QtWebProcess() [0x400b19]
STDERR: 29  0x7fdcda73830d /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7fdcda73830d]
STDERR: 30  0x400ba1 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/bin/QtWebProcess() [0x400ba1]

Crash log for fast/css/getComputedStyle/computed-style-display-none.html:
--------------------------------------------------------------------------
crash log for WebProcess (pid <unknown>):
STDOUT: <empty>
STDERR: 1   0x7fcbc8272c18 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libWTRInjectedBundle.so(+0x35c18) [0x7fcbc8272c18]
STDERR: 2   0x7fcc14912420 /lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7fcc14912420]
STDERR: 3   0x7fcc153d8b13 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(+0x23eb13) [0x7fcc153d8b13]
STDERR: 4   0x7fcc153d5014 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QObjectPrivate::setParent_helper(QObject*)+0x1c4) [0x7fcc153d5014]
STDERR: 5   0x7fcc153d5b8e /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QObject::~QObject()+0x57e) [0x7fcc153d5b8e]
STDERR: 6   0x7fcc16e573a6 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WorkQueue::WorkItemQt::~WorkItemQt()+0x36) [0x7fcc16e573a6]
STDERR: 7   0x7fcc153d0afe /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QObject::event(QEvent*)+0x34e) [0x7fcc153d0afe]
STDERR: 8   0x7fcc15971bf4 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0xb4) [0x7fcc15971bf4]
STDERR: 9   0x7fcc15974c5d /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplication::notify(QObject*, QEvent*)+0x3ad) [0x7fcc15974c5d]
STDERR: 10  0x7fcc153a9b44 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x84) [0x7fcc153a9b44]
STDERR: 11  0x7fcc153abe88 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*)+0x308) [0x7fcc153abe88]
STDERR: 12  0x7fcc153f0dc3 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(+0x256dc3) [0x7fcc153f0dc3]
STDERR: 13  0x7fcc0fe48a5d /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x1dd) [0x7fcc0fe48a5d]
STDERR: 14  0x7fcc0fe49258 /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x45258) [0x7fcc0fe49258]
STDERR: 15  0x7fcc0fe49429 /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x69) [0x7fcc0fe49429]
STDERR: 16  0x7fcc153f1224 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x64) [0x7fcc153f1224]
STDERR: 17  0x7fcc153a8a7b /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0xdb) [0x7fcc153a8a7b]
STDERR: 18  0x7fcc152189a9 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QThread::exec()+0xd9) [0x7fcc152189a9]
STDERR: 19  0x7fcc1521e0fc /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(+0x840fc) [0x7fcc1521e0fc]
STDERR: 20  0x7fcc11ba7efc /lib/x86_64-linux-gnu/libpthread.so.0(+0x7efc) [0x7fcc11ba7efc]
STDERR: 21  0x7fcc149bf59d /lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fcc149bf59d]
STDERR: 1   0x7fcbc8272c18 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libWTRInjectedBundle.so(+0x35c18) [0x7fcbc8272c18]
STDERR: 2   0x7fcc14912420 /lib/x86_64-linux-gnu/libc.so.6(+0x36420) [0x7fcc14912420]
STDERR: 3   0x7fcc17141bbc /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::QualifiedName::deref()+0xc) [0x7fcc17141bbc]
STDERR: 4   0x7fcc1710f238 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::Element::~Element()+0x88) [0x7fcc1710f238]
STDERR: 5   0x7fcc1726c6c1 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::HTMLDivElement::~HTMLDivElement()+0x21) [0x7fcc1726c6c1]
STDERR: 6   0x7fcc16f708e2 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::JSNodeOwner::finalize(JSC::Handle<JSC::Unknown>, void*)+0x122) [0x7fcc16f708e2]
STDERR: 7   0x7fcc17fa8e81 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::WeakBlock::sweep()+0x81) [0x7fcc17fa8e81]
STDERR: 8   0x7fcc17fa8b15 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::WeakSet::sweep()+0x65) [0x7fcc17fa8b15]
STDERR: 9   0x7fcc17fb2d8b /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::MarkedSpace::sweepWeakSets()+0x7b) [0x7fcc17fb2d8b]
STDERR: 10  0x7fcc17fac7b5 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(JSC::Heap::collect(JSC::Heap::SweepToggle)+0x75) [0x7fcc17fac7b5]
STDERR: 11  0x7fcc16f0fdfa /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(+0xeb4dfa) [0x7fcc16f0fdfa]
STDERR: 12  0x7fcc1759b132 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::ThreadTimers::sharedTimerFiredInternal()+0xa2) [0x7fcc1759b132]
STDERR: 13  0x7fcc153d0819 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QObject::event(QEvent*)+0x69) [0x7fcc153d0819]
STDERR: 14  0x7fcc15971bf4 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0xb4) [0x7fcc15971bf4]
STDERR: 15  0x7fcc15974c5d /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtWidgets.so.5(QApplication::notify(QObject*, QEvent*)+0x3ad) [0x7fcc15974c5d]
STDERR: 16  0x7fcc153a9b44 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x84) [0x7fcc153a9b44]
STDERR: 17  0x7fcc153f01dc /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QTimerInfoList::activateTimers()+0x47c) [0x7fcc153f01dc]
STDERR: 18  0x7fcc153f0a5d /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(+0x256a5d) [0x7fcc153f0a5d]
STDERR: 19  0x7fcc0fe48a5d /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x1dd) [0x7fcc0fe48a5d]
STDERR: 20  0x7fcc0fe49258 /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x45258) [0x7fcc0fe49258]
STDERR: 21  0x7fcc0fe49429 /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x69) [0x7fcc0fe49429]
STDERR: 22  0x7fcc153f1224 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x64) [0x7fcc153f1224]
STDERR: 23  0x7fcc153a8a7b /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0xdb) [0x7fcc153a8a7b]
STDERR: 24  0x7fcc153ac3b0 /usr/local/Trolltech/Qt5/Qt-5.0.0-r31/lib/libQtCore.so.5(QCoreApplication::exec()+0x80) [0x7fcc153ac3b0]
STDERR: 25  0x7fcc1778ae6c /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebCore::RunLoop::run()+0x5c) [0x7fcc1778ae6c]
STDERR: 26  0x7fcc16e54fdd /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/lib/libQtWebKit.so.5(WebKit::WebProcessMainQt(QGuiApplication*)+0x37d) [0x7fcc16e54fdd]
STDERR: 27  0x400b19 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/bin/QtWebProcess() [0x400b19]
STDERR: 28  0x7fcc148fd30d /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7fcc148fd30d]
STDERR: 29  0x400ba1 /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/WebKitBuild/Release/bin/QtWebProcess() [0x400ba1]

You can easily reproduce these crashes with Qt5-WebKit with the following commands:
- Tools/Scripts/run-webkit-tests -2 fast/css/getComputedStyle/computed-style-border-image.html fast/css/getComputedStyle/computed-style-cross-fade.html fast/css/getComputedStyle/computed-style-display-none.html
- Tools/Scripts/run-webkit-tests -2 fast/backgrounds/multiple-backgrounds-assert.html fast/backgrounds/multiple-backgrounds-computed-style.html fast/backgrounds/opacity-on-document-element.html
(The individual tests don't crash in itself, but with these commands or if you run the whole directory)
Comment 1 Csaba Osztrogonác 2012-05-29 08:56:34 PDT
Maybe this bug is related to https://bugs.webkit.org/show_bug.cgi?id=87701
Comment 2 Andreas Kling 2012-05-29 10:43:07 PDT
Caio, could you lend a hand with this? I can't reproduce any troubles on Mac port.
Comment 3 Caio Marcelo de Oliveira Filho 2012-05-29 12:01:24 PDT
(In reply to comment #2)
> Caio, could you lend a hand with this? I can't reproduce any troubles on Mac port.

Compiling in debug mode to see if I can reproduce this.
Comment 4 Caio Marcelo de Oliveira Filho 2012-05-29 12:28:32 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Caio, could you lend a hand with this? I can't reproduce any troubles on Mac port.
> 
> Compiling in debug mode to see if I can reproduce this.

I can reproduce at least the first crash. Need to go home now, but can look at this by tomorrow.
Comment 5 Csaba Osztrogonác 2012-05-30 00:16:23 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Caio, could you lend a hand with this? I can't reproduce any troubles on Mac port.
> 
> Compiling in debug mode to see if I can reproduce this.

It isn't a good idea, because almost everything crash in debug mode because of https://bugs.webkit.org/show_bug.cgi?id=87701
Comment 6 Csaba Osztrogonác 2012-06-01 01:33:37 PDT
Is there any progression on fixing this regression?

It seems it is unrelated to https://bugs.webkit.org/show_bug.cgi?id=87701,
I tried the proposed patch in it, but it didn't help for this bug. But
it could help debugging, because with that patch, debug build works again.
Comment 7 Csaba Osztrogonác 2012-06-01 05:51:42 PDT
I skipped 2 tests to paint the bot green - r119221

+# [Qt][WK2] REGRESSION(r118761): It made 2 tests crash
+# https://bugs.webkit.org/show_bug.cgi?id=87750
+fast/backgrounds/multiple-backgrounds-computed-style.html
+fast/css/getComputedStyle/computed-style-cross-fade.html
Comment 8 Csaba Osztrogonác 2012-10-09 00:07:09 PDT
Somebody fixed it, but forget to comment the bug and unskip the tests ... Unskip landed in r130724.