Bug 87719 - REGRESSION(r111497): The "option" element doesn't match CSS pseudo class :enabled
Summary: REGRESSION(r111497): The "option" element doesn't match CSS pseudo class :ena...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: yosin
URL:
Keywords: InRadar, Regression
Depends on:
Blocks: 80381
  Show dependency treegraph
 
Reported: 2012-05-29 03:01 PDT by yosin
Modified: 2012-05-29 21:34 PDT (History)
6 users (show)

See Also:


Attachments
Patch 1 (25.21 KB, patch)
2012-05-29 18:51 PDT, yosin
no flags Details | Formatted Diff | Diff
Patch 2 (25.21 KB, patch)
2012-05-29 19:16 PDT, yosin
no flags Details | Formatted Diff | Diff
Patch 3 (25.21 KB, patch)
2012-05-29 21:08 PDT, yosin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yosin 2012-05-29 03:01:37 PDT
In SelectorChecker::checkOneSelector, following code fragment should check element->hasTagName(optionTag).
Because, r111497 changed base class of HTMLOptionElement to HTMLElement from HTMLFormControlElement.

        case CSSSelector::PseudoEnabled:
            if (element && element->isFormControlElement())
                return element->isEnabledFormControl();
            break;
Comment 1 yosin 2012-05-29 18:51:34 PDT
Created attachment 144673 [details]
Patch 1
Comment 2 yosin 2012-05-29 18:52:15 PDT
Comment on attachment 144673 [details]
Patch 1

Could you review this patch?
Thanks in advance.
Comment 3 Kent Tamura 2012-05-29 18:55:54 PDT
Comment on attachment 144673 [details]
Patch 1

View in context: https://bugs.webkit.org/attachment.cgi?id=144673&action=review

> Source/WebCore/css/SelectorChecker.cpp:1054
> -            if (element && (element->isFormControlElement() ||  element->hasTagName(optgroupTag)))
> +            if (element && (element->isFormControlElement() || element->hasTagName(optionTag) ||  element->hasTagName(optgroupTag)))

Would you remove one space after the second || please?
Comment 4 mitz 2012-05-29 18:57:27 PDT
<rdar://problem/11553964>
Comment 5 yosin 2012-05-29 19:16:08 PDT
Created attachment 144677 [details]
Patch 2
Comment 6 yosin 2012-05-29 19:16:38 PDT
Comment on attachment 144677 [details]
Patch 2

Remove an extra space.
Comment 7 WebKit Review Bot 2012-05-29 21:05:14 PDT
Comment on attachment 144677 [details]
Patch 2

Rejecting attachment 144677 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 1

ERROR: /mnt/git/webkit-commit-queue/LayoutTests/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://queues.webkit.org/results/12845746
Comment 8 yosin 2012-05-29 21:08:37 PDT
Created attachment 144690 [details]
Patch 3
Comment 9 WebKit Review Bot 2012-05-29 21:34:49 PDT
Comment on attachment 144690 [details]
Patch 3

Clearing flags on attachment: 144690

Committed r118891: <http://trac.webkit.org/changeset/118891>
Comment 10 WebKit Review Bot 2012-05-29 21:34:58 PDT
All reviewed patches have been landed.  Closing bug.