Bug 87693 - [GStreamer] Video sink doesn't respect WebKit code style
Summary: [GStreamer] Video sink doesn't respect WebKit code style
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Philippe Normand
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-28 22:14 PDT by Philippe Normand
Modified: 2012-05-29 09:28 PDT (History)
7 users (show)

See Also:


Attachments
Patch (25.13 KB, patch)
2012-05-28 22:16 PDT, Philippe Normand
menard: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2012-05-28 22:14:10 PDT
SSIA
Comment 1 Philippe Normand 2012-05-28 22:16:43 PDT
Created attachment 144444 [details]
Patch
Comment 2 WebKit Review Bot 2012-05-28 22:20:15 PDT
Attachment 144444 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.h:59:  webkit_video_sink_get_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 1 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alexis Menard (darktears) 2012-05-29 04:11:59 PDT
Comment on attachment 144444 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=144444&action=review

Other that the comment rs=me

> Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:42
> +static GstStaticPadTemplate sinkTemplate = GST_STATIC_PAD_TEMPLATE("sink", GST_PAD_SINK, GST_PAD_ALWAYS, GST_STATIC_CAPS(WEBKIT_VIDEO_SINK_PAD_CAPS));

The static variable should start with s_ isn't it?
Comment 4 Philippe Normand 2012-05-29 09:20:29 PDT
(In reply to comment #3)
> (From update of attachment 144444 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=144444&action=review
> 
> Other that the comment rs=me
> 
> > Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer.cpp:42
> > +static GstStaticPadTemplate sinkTemplate = GST_STATIC_PAD_TEMPLATE("sink", GST_PAD_SINK, GST_PAD_ALWAYS, GST_STATIC_CAPS(WEBKIT_VIDEO_SINK_PAD_CAPS));
> 
> The static variable should start with s_ isn't it?

Ah yes indeed. Thanks for the review!
Comment 5 Philippe Normand 2012-05-29 09:28:07 PDT
Committed r118789: <http://trac.webkit.org/changeset/118789>