Bug 8765 - Random crashes on TOT since the form state change
: Random crashes on TOT since the form state change
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Forms
: 420+
: Macintosh Mac OS X 10.4
: P1 Major
Assigned To: Darin Adler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 01:26 PDT by Maciej Stachowiak
Modified: 2006-05-07 22:54 PDT (History)
1 user (show)

See Also:


Attachments
patch based on Mitz's analysis (3.29 KB, patch)
2006-05-07 10:48 PDT, Darin Adler
no flags Details | Formatted Diff | Diff
patch with improved change log (3.63 KB, patch)
2006-05-07 10:56 PDT, Darin Adler
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2006-05-07 01:26:06 PDT
The recent form state change apparently caused a bunch of random memory trashers. Here's one set of steps that consistently reproduces a crash for me:

1) Go to http://www.cnn.com and wait for it to fully load.
2) Click any link.
3) Go back.

Darin has a patch for this attached to a bug where this was misdiagnosed as the cause.
Comment 1 mitz@webkit.org 2006-05-07 04:46:53 PDT
Darin's patch is attached to bug 8753.
Comment 2 Darin Adler 2006-05-07 10:48:54 PDT
Created attachment 8144 [details]
patch based on Mitz's analysis
Comment 3 Darin Adler 2006-05-07 10:56:18 PDT
Created attachment 8145 [details]
patch with improved change log
Comment 4 Maciej Stachowiak 2006-05-07 21:45:42 PDT
Comment on attachment 8145 [details]
patch with improved change log

r=me
Comment 5 Maciej Stachowiak 2006-05-07 21:52:21 PDT
People have been complaining about the crasher so I went ahead and commited this, hope you don't mind, Darin.
Comment 6 Darin Adler 2006-05-07 22:54:03 PDT
(In reply to comment #5)
> People have been complaining about the crasher so I went ahead and commited
> this, hope you don't mind, Darin.

Not at all. I've been waiting on review or I would have committed a while back.