Bug 87038 - Web Inspector: $_ for last calculated result
Summary: Web Inspector: $_ for last calculated result
Status: RESOLVED DUPLICATE of bug 93377
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 12:49 PDT by homakov
Modified: 2012-08-07 11:22 PDT (History)
12 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description homakov 2012-05-21 12:49:15 PDT
It would be nice to have smth like __ or $_ variable available in console - it is _ in Ruby.
It will save some time and also suits since we already have $0-4 for latest DOM elements.
Also implementation is only 1 LOC.
Comment 1 Pavel Feldman 2012-05-21 13:37:06 PDT
Sounds good to me. Do you have a patch?
Comment 2 homakov 2012-05-21 13:42:11 PDT
not yet. Just need more "+1" - and it will be committed!
Comment 3 Pavel Feldman 2012-05-21 13:50:22 PDT
(In reply to comment #2)
> not yet. Just need more "+1" - and it will be committed!

You don't need more "+1", feel free to attach the patch and I'll review it. Note that this change would need a test. See LayoutTests/inspector/console/command-line-api.html and other command-line tests for more info.
Comment 4 homakov 2012-05-25 01:09:09 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > not yet. Just need more "+1" - and it will be committed!
> 
> You don't need more "+1", feel free to attach the patch and I'll review it. Note that this change would need a test. See LayoutTests/inspector/console/command-line-api.html and other command-line tests for more info.

Great. Just having some issues with contexts - learning how webinspector works with $0-4 and doesn't pollute current window JS namespace.
Comment 5 Paul Irish 2012-08-07 11:22:36 PDT

*** This bug has been marked as a duplicate of bug 93377 ***