Bug 87020 - run-webkit-tests fails when svn is not installed
Summary: run-webkit-tests fails when svn is not installed
Status: RESOLVED DUPLICATE of bug 76630
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 07:51 PDT by Lauro Moura Maranhao Neto
Modified: 2012-06-19 07:20 PDT (History)
6 users (show)

See Also:


Attachments
Adds try/except guard around the svn call (1.69 KB, patch)
2012-05-21 07:56 PDT, Lauro Moura Maranhao Neto
rniwa: review-
rniwa: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lauro Moura Maranhao Neto 2012-05-21 07:51:00 PDT
Revision 117643 added a call to the svn executable without a try/except guard to avoid raising the exception when svn is not installed.
Comment 1 Lauro Moura Maranhao Neto 2012-05-21 07:56:02 PDT
Created attachment 143033 [details]
Adds try/except guard around the svn call
Comment 2 Adam Barth 2012-05-21 09:11:31 PDT
Comment on attachment 143033 [details]
Adds try/except guard around the svn call

Can we test this change?
Comment 3 Ryosuke Niwa 2012-05-21 17:04:17 PDT
Comment on attachment 143033 [details]
Adds try/except guard around the svn call

View in context: https://bugs.webkit.org/attachment.cgi?id=143033&action=review

> Tools/Scripts/webkitpy/common/checkout/scm/svn.py:97
> +        try:
> +            exit_code = Executive().run_command(svn_info_args, cwd=path, return_exit_code=True)
> +            return (exit_code == 0)
> +        except OSError:
> +            return False

We need a test for this. r- due to the lack of a test.
Comment 4 Rafael Brandao 2012-06-18 14:38:43 PDT
I confirm this bug (spent some time to figure out the lack of subversion).
Could we at least print a more meaningful message when this error shows up?
Comment 5 Rafael Brandao 2012-06-18 14:48:37 PDT
On a side note, it also fails when xvfb is missing:

(...)
  File "/opt/git/webkit/Tools/Scripts/webkitpy/layout_tests/port/driver.py", line 220, in run_test
    return self._running_drivers[cmd_line_key].run_test(driver_input)
  File "/opt/git/webkit/Tools/Scripts/webkitpy/layout_tests/port/webkit.py", line 558, in run_test
    self.start(driver_input.should_run_pixel_test, driver_input.args)
  File "/opt/git/webkit/Tools/Scripts/webkitpy/layout_tests/port/webkit.py", line 670, in start
    self._start(pixel_tests, per_test_args)
  File "/opt/git/webkit/Tools/Scripts/webkitpy/layout_tests/port/xvfbdriver.py", line 59, in _start
    self._xvfb_process = subprocess.Popen(run_xvfb, stderr=devnull)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Comment 6 Rafael Brandao 2012-06-19 07:20:00 PDT

*** This bug has been marked as a duplicate of bug 76630 ***