Bug 86748 - REGRESSION (r117428): WebKit API/SPI was removed
Summary: REGRESSION (r117428): WebKit API/SPI was removed
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
: 86729 86735 86737 86740 (view as bug list)
Depends on:
Blocks: 86704
  Show dependency treegraph
 
Reported: 2012-05-17 09:30 PDT by WebKit Review Bot
Modified: 2012-05-17 12:19 PDT (History)
8 users (show)

See Also:


Attachments
ROLLOUT of r117428 (46.21 KB, patch)
2012-05-17 09:31 PDT, WebKit Review Bot
webkit.review.bot: commit-queue?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-05-17 09:30:36 PDT
http://trac.webkit.org/changeset/117428 broke the build:
It broke the Safari build (Requested by jessieberlin on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-05-17 09:31:30 PDT
Created attachment 142489 [details]
ROLLOUT of r117428

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Jessie Berlin 2012-05-17 09:35:18 PDT
Looks like the attached patch is bogus. This will need to be done by hand.

The reason that this broke the Safari build is that it removed API / SPI that Safari was using.
Comment 3 mitz 2012-05-17 10:27:06 PDT
Reverted r117428 in <http://trac.webkit.org/r117460>.
Comment 4 Alexey Proskuryakov 2012-05-17 11:37:14 PDT
*** Bug 86735 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Proskuryakov 2012-05-17 11:37:26 PDT
*** Bug 86737 has been marked as a duplicate of this bug. ***
Comment 6 Alexey Proskuryakov 2012-05-17 11:37:52 PDT
*** Bug 86729 has been marked as a duplicate of this bug. ***
Comment 7 Alexey Proskuryakov 2012-05-17 11:38:19 PDT
*** Bug 86740 has been marked as a duplicate of this bug. ***
Comment 8 Eric Seidel (no email) 2012-05-17 12:14:05 PDT
Comment on attachment 142489 [details]
ROLLOUT of r117428

View in context: https://bugs.webkit.org/attachment.cgi?id=142489&action=review

> Source/WebCore/ChangeLog:16
> +2012-05-17  Pavel Feldman  <pfeldman@chromium.org>

This changelog loks wrong, but otherwise the patch looks fine.  I wonder why the sherrif-bot goofed here.
Comment 9 Eric Seidel (no email) 2012-05-17 12:19:01 PDT
Thank you mitz.