Bug 86589 - [Chromium] WebTransformationMatrixTest.verifyDefaultConstructorCreatesIdentityMatrix is failing
Summary: [Chromium] WebTransformationMatrixTest.verifyDefaultConstructorCreatesIdentit...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Shawn Singh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-16 00:42 PDT by Kenichi Ishibashi
Modified: 2012-05-16 11:20 PDT (History)
8 users (show)

See Also:


Attachments
Patch (3.22 KB, patch)
2012-05-16 02:18 PDT, Kenichi Ishibashi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Kenichi Ishibashi 2012-05-16 02:18:31 PDT
Created attachment 142202 [details]
Patch
Comment 2 WebKit Review Bot 2012-05-16 02:20:53 PDT
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Comment 3 Kenichi Ishibashi 2012-05-16 02:22:26 PDT
The failure is caused by the assertion at WebPrivateOwnPtr::~WebPrivateOwnPtr().

Kent-san, could you take a look?
Comment 4 Kent Tamura 2012-05-16 02:57:25 PDT
Comment on attachment 142202 [details]
Patch

ok
Comment 5 Kenichi Ishibashi 2012-05-16 03:13:33 PDT
(In reply to comment #4)
> (From update of attachment 142202 [details])
> ok

Thanks!
Comment 6 WebKit Review Bot 2012-05-16 04:19:38 PDT
Comment on attachment 142202 [details]
Patch

Clearing flags on attachment: 142202

Committed r117257: <http://trac.webkit.org/changeset/117257>
Comment 7 WebKit Review Bot 2012-05-16 04:19:44 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Shawn Singh 2012-05-16 08:40:34 PDT
Thank you for fixing this, I apologize you had to do it on my behalf
Comment 9 James Robinson 2012-05-16 11:20:33 PDT
Comment on attachment 142202 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=142202&action=review

> Source/Platform/chromium/public/WebTransformationMatrix.h:54
> +    ~WebTransformationMatrix();

we typically have this declared inline and call a exported reset() function. this class is still in a bit of flux, though (it doesn't have proper exports yet, for instance)