Bug 86148 - [Qt] Fix build after QPA file renaming
Summary: [Qt] Fix build after QPA file renaming
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2012-05-10 14:43 PDT by Donald Carr
Modified: 2012-05-16 07:56 PDT (History)
7 users (show)

See Also:


Attachments
build fix (1.96 KB, patch)
2012-05-10 14:45 PDT, Donald Carr
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Donald Carr 2012-05-10 14:43:45 PDT
Fixes Webkit to build after:

https://codereview.qt-project.org/#change,23443
Comment 1 Donald Carr 2012-05-10 14:45:45 PDT
Created attachment 141268 [details]
build fix
Comment 2 WebKit Review Bot 2012-05-10 14:49:53 PDT
Attachment 141268 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/plugins/qt/PluginViewQt.cpp:87:  Alphabetical sorting problem.  [build/include_order] [4]
Total errors found: 1 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Early Warning System Bot 2012-05-10 15:19:24 PDT
Comment on attachment 141268 [details]
build fix

Attachment 141268 [details] did not pass qt-wk2-ews (qt):
Output: http://queues.webkit.org/results/12672096
Comment 4 Csaba Osztrogonác 2012-05-14 04:55:10 PDT
It seems it is what I searched. :) Let me try it.
Comment 5 Csaba Osztrogonác 2012-05-14 05:44:31 PDT
The build works fine, but unfortunately there is a serious regression in Qt5 somewhere, because _all_ tests crash with this backtrace:

$ run-in-xvfb.sh gdb WebKitBuild/Debug/bin/DumpRenderTree

GNU gdb (GDB) 7.0.1-debian
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/oszi/WebKit/WebKitBuild/Debug/bin/DumpRenderTree...done.

(gdb) run css2.1/t0402-c71-fwd-parsing-00-f.html

Starting program: /home/oszi/WebKit/WebKitBuild/Debug/bin/DumpRenderTree css2.1/t0402-c71-fwd-parsing-00-f.html
[Thread debugging using libthread_db enabled]

Program received signal SIGABRT, Aborted.
0x00007fffebfe91b5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64      ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
        in ../nptl/sysdeps/unix/sysv/linux/raise.c
Current language:  auto
The current source language is "auto; currently c".
(gdb) bt
#0  0x00007fffebfe91b5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007fffebfebfc0 in *__GI_abort () at abort.c:92
#2  0x00007fffecfe3c45 in qt_message_output(QtMsgType, QMessageLogContext const&, QString const&) ()
   from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtCore.so.5
#3  0x00007fffecfe41b6 in ?? () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtCore.so.5
#4  0x00007fffecfe4353 in QMessageLogger::fatal(char const*, ...) () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtCore.so.5
#5  0x00007fffed6c9c5d in QGuiApplicationPrivate::createPlatformIntegration() () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtGui.so.5
#6  0x00007fffed6cadbd in QGuiApplicationPrivate::createEventDispatcher() () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtGui.so.5
#7  0x00007fffed18e00a in QCoreApplication::init() () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtCore.so.5
#8  0x00007fffed18e275 in QCoreApplication::QCoreApplication(QCoreApplicationPrivate&) () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtCore.so.5
#9  0x00007fffed6cab8d in QGuiApplication::QGuiApplication(QGuiApplicationPrivate&) () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtGui.so.5
#10 0x00007fffeed1d6e7 in QApplication::QApplication(int&, char**, int) () from /usr/local/Trolltech/Qt5/Qt-5.0.0-r30c/lib/libQtWidgets.so.5
#11 0x000000000042d33a in main (argc=2, argv=0x7fffffffe368) at /home/oszi/WebKit/Tools/DumpRenderTree/qt/main.cpp:152


5146b9449d58b2c3fe54173ebbdfb07b6e0da19f is the latest working Qt5 hash and df4acd4b44261fed883c456b77e442a4234aa746 has this bug. (and the latest 47e8da3a178579ac4c05feb66db9cfafc0fe64d6 has it too)
Comment 6 Noam Rosenthal 2012-05-14 07:25:24 PDT
(In reply to comment #5)
> The build works fine, but unfortunately there is a serious regression in Qt5 somewhere, because _all_ tests crash with this backtrace:
> 
> $ run-in-xvfb.sh gdb WebKitBuild/Debug/bin/DumpRenderTree
> #4  0x00007fffecfe4353 in QMessageLogger::fatal(char const*, ...) () from 

Do we know what the fatal error log actually is?
Comment 7 Csaba Osztrogonác 2012-05-14 07:26:46 PDT
How can I get it?
Comment 8 Noam Rosenthal 2012-05-14 07:32:11 PDT
(In reply to comment #7)
> How can I get it?
It should be in stderr right before the crash.
Comment 9 Csaba Osztrogonác 2012-05-14 08:02:33 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > How can I get it?
> It should be in stderr right before the crash.

I can't find any additionalt error, I copy/pasted the full log.
Comment 10 Csaba Osztrogonác 2012-05-15 02:10:53 PDT
Simon found the culprit, thanks for it: configure disabled XCB because of missing libxcb-randr0-dev package. It is a new dependency for XCB after this qtbase commit: f280efc6201adf8933c9d48a1d5b6983ee9fed9b

I'll rebuild Qt5 again and test WebKit with it.
Comment 11 Csaba Osztrogonác 2012-05-16 07:53:38 PDT
Comment on attachment 141268 [details]
build fix

r=me
Comment 12 Csaba Osztrogonác 2012-05-16 07:56:03 PDT
Comment on attachment 141268 [details]
build fix

Clearing flags on attachment: 141268

Committed r117291: <http://trac.webkit.org/changeset/117291>
Comment 13 Csaba Osztrogonác 2012-05-16 07:56:15 PDT
All reviewed patches have been landed.  Closing bug.