Bug 86020 - Fix overzealous re-opened since blocked by... message
: Fix overzealous re-opened since blocked by... message
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Tom Zakrajsek
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 14:47 PDT by WebKit Review Bot
Modified: 2012-05-09 16:21 PDT (History)
4 users (show)

See Also:


Attachments
Patch (11.99 KB, patch)
2012-05-09 15:14 PDT, Tom Zakrajsek
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-05-09 14:47:02 PDT
Fix overzealous re-opened since blocked by... message
Requested by tomz_ on #webkit.
Comment 1 Tom Zakrajsek 2012-05-09 14:57:43 PDT
The problem is demonstrated in the comments of https://bugs.webkit.org/show_bug.cgi?id=66687.  Due to http://trac.webkit.org/changeset/116245, bugs are getting stamped with "Re-opened since this is blocked by <bug number>" if a new bug is created and set to block it.  This happens whether or not the blocked bug was already open.

Change the behavior to only do the re-open and stamp if the blocked bug was already resolved.
Comment 2 Tom Zakrajsek 2012-05-09 15:14:15 PDT
Created attachment 141025 [details]
Patch
Comment 3 WebKit Review Bot 2012-05-09 16:21:22 PDT
Comment on attachment 141025 [details]
Patch

Clearing flags on attachment: 141025

Committed r116572: <http://trac.webkit.org/changeset/116572>
Comment 4 WebKit Review Bot 2012-05-09 16:21:27 PDT
All reviewed patches have been landed.  Closing bug.