Bug 85975 - Improve a warning message for a reftest having an unused expectation file.
Summary: Improve a warning message for a reftest having an unused expectation file.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Hayato Ito
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-09 03:28 PDT by Hayato Ito
Modified: 2012-05-09 20:24 PDT (History)
5 users (show)

See Also:


Attachments
Improve a warning message. (1.76 KB, patch)
2012-05-09 03:31 PDT, Hayato Ito
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hayato Ito 2012-05-09 03:28:02 PDT
The current warning message is not intuitive. It might be better to update the message.
Comment 1 Hayato Ito 2012-05-09 03:31:07 PDT
Created attachment 140904 [details]
Improve a warning message.
Comment 2 Dirk Pranke 2012-05-09 12:28:24 PDT
Comment on attachment 140904 [details]
Improve a warning message.

This might be bikeshedding, but "expectation file" == test_expectations.txt to me. I'd probably call it a "expected baseline"
Comment 3 Ojan Vafai 2012-05-09 14:03:11 PDT
(In reply to comment #2)
> (From update of attachment 140904 [details])
> This might be bikeshedding, but "expectation file" == test_expectations.txt to me. I'd probably call it a "expected baseline"

Not really true historically for WebKit though. baseline is a chromium-ism that we've leaked in, so now it's a mess where people use the terms interchangeably.
Comment 4 Hayato Ito 2012-05-09 18:46:17 PDT
Thank you for comments, guys.
Let me land this patch as is anyway. If term of 'expectation file' causes confusion, I'm happy to modify it later.

(In reply to comment #3)
> (In reply to comment #2)
> > (From update of attachment 140904 [details] [details])
> > This might be bikeshedding, but "expectation file" == test_expectations.txt to me. I'd probably call it a "expected baseline"
> 
> Not really true historically for WebKit though. baseline is a chromium-ism that we've leaked in, so now it's a mess where people use the terms interchangeably.
Comment 5 WebKit Review Bot 2012-05-09 20:24:00 PDT
Comment on attachment 140904 [details]
Improve a warning message.

Clearing flags on attachment: 140904

Committed r116600: <http://trac.webkit.org/changeset/116600>
Comment 6 WebKit Review Bot 2012-05-09 20:24:05 PDT
All reviewed patches have been landed.  Closing bug.