Bug 85376 - REGRESSION (r115829): broke fullscreen/video-controls-drag.html on GTK
Summary: REGRESSION (r115829): broke fullscreen/video-controls-drag.html on GTK
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2012-05-02 08:13 PDT by Philippe Normand
Modified: 2012-11-27 00:44 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2012-05-02 08:13:00 PDT
--- /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/fullscreen/video-controls-drag-expected.txt 
+++ /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/fullscreen/video-controls-drag-actual.txt 
@@ -1,7 +1,7 @@
 This tests that the video element's controls are draggable in full screen. Press any key to continue.
 
 EVENT(webkitfullscreenchange)
-EXPECTED (endBox.left - startBox.left == '15') OK
-EXPECTED (endBox.top - startBox.top == '15') OK
+EXPECTED (endBox.left - startBox.left == '15'), OBSERVED '0' FAIL
+EXPECTED (endBox.top - startBox.top == '15'), OBSERVED '0' FAIL
 END OF TEST
Comment 1 Philippe Normand 2012-05-02 08:13:51 PDT
I will flag it, no time to check the issue now but I guess the controls panel height update from 100% to 20px is the cause of this regression.
Comment 2 Zan Dobersek 2012-11-27 00:44:30 PST
The test is passing now, will be removed from TestExpectations.