Bug 85220 - SVG vertical lines with dasharray 1,1 do not render
Summary: SVG vertical lines with dasharray 1,1 do not render
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-30 11:28 PDT by Philip Rogers
Modified: 2022-06-29 16:56 PDT (History)
5 users (show)

See Also:


Attachments
Testcase (4.99 KB, image/svg+xml)
2012-04-30 11:28 PDT, Philip Rogers
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Rogers 2012-04-30 11:28:30 PDT
Created attachment 139487 [details]
Testcase

As the description says, vertical lines with dasharray 1,1 do not render (probably Skia related).

In the attached testcase you should see a grid of dotted lines but Chrome just renders the horizontal ones.

Original bug: crbug.com/35796
Comment 1 Rob Buis 2012-04-30 12:53:50 PDT
It does seem Skia related, it works fine in QtWebKit and Safari trunk.
Comment 2 Ahmad Saleem 2022-06-29 16:17:52 PDT
I am unable to reproduce this bug in Safari 15.5 on macOS 12.4 and also on Safari TP 148. It matches with all other browsers (Chrome Canary 105 and Firefox Nightly 104). Even the corresponding Chrome bug was marked as WONTFIX after someone tested in 2014 and concluded that now it is working as intended.

If it is still issues on other Webkit builds then I think it can be kept open else I think we can close it (if there is any WPT or test case coverage available to capture this). Thanks!
Comment 3 Alexey Proskuryakov 2022-06-29 16:56:33 PDT
Resolving as INVALID, as this only ever affected Chrome.