Bug 84971 - Regression: CSS transitions declared on :hover do not fire on mouseleave
: Regression: CSS transitions declared on :hover do not fire on mouseleave
Status: RESOLVED WORKSFORME
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Nobody
http://jsbin.com/iqozik/edit#html,live
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 09:54 PDT by Paul Irish
Modified: 2012-04-27 11:32 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Irish 2012-04-26 09:54:53 PDT
1) Open http://jsbin.com/iqozik/edit#html,live
2) hover on green box
3) move cursor off of it
4) it should spin

Stable Safari and Chrome do spin, but Webkit Nightly and Canary fail to.
Comment 1 Simon Fraser (smfr) 2012-04-26 13:20:57 PDT
Works for me in a WebKit build at r115338.
Comment 2 Paul Irish 2012-04-27 11:32:48 PDT
Was broken in an earlier WebKit build for me, but I can confirm this is fine in Nightly.
Still broken in latest Canary though. I'll file downstream.