Bug 8467 - Block with percentage background-size doesn't repaint properly when it grows
Summary: Block with percentage background-size doesn't repaint properly when it grows
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Beth Dakin
URL:
Keywords:
: 8466 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-18 16:08 PDT by Dave Hyatt
Modified: 2006-04-19 12:50 PDT (History)
1 user (show)

See Also:


Attachments
Test case (1.53 KB, text/html)
2006-04-19 10:33 PDT, Beth Dakin
no flags Details
Image for test case (6.24 KB, image/jpeg)
2006-04-19 10:33 PDT, Beth Dakin
no flags Details
Patch (768 bytes, patch)
2006-04-19 10:39 PDT, Beth Dakin
hyatt: review+
Details | Formatted Diff | Diff
Test case that works in Bugzilla (1.67 KB, text/html)
2006-04-19 10:45 PDT, Beth Dakin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2006-04-18 16:08:16 PDT
This is a bug to track the issue I mentioned on IRC where mustPaintBackgroundOrBorder in RenderObject.cpp needs to return true if you have a percentage background-size.  This will need a manual test.
Comment 1 Beth Dakin 2006-04-18 16:10:08 PDT
*** Bug 8466 has been marked as a duplicate of this bug. ***
Comment 2 Beth Dakin 2006-04-19 10:33:30 PDT
Created attachment 7837 [details]
Test case

Here is a test case I made based on a test Mitz made for a similar problem.
Comment 3 Beth Dakin 2006-04-19 10:33:58 PDT
Created attachment 7838 [details]
Image for test case
Comment 4 Beth Dakin 2006-04-19 10:39:58 PDT
Created attachment 7839 [details]
Patch

Here is a patch that fixes the problem. I can't seem to reproduce thh bug with a fixed background size, so I think I only need to check for percent.
Comment 5 Beth Dakin 2006-04-19 10:45:49 PDT
Created attachment 7840 [details]
Test case that works in Bugzilla

I just realized that the other test case won't find the background-image I specified, so here is a version of the test that links to an internet-based image so that the test works in Bugzilla. I will check in the other version, of course.
Comment 6 Dave Hyatt 2006-04-19 12:04:20 PDT
Comment on attachment 7839 [details]
Patch

r=me
Comment 7 Beth Dakin 2006-04-19 12:50:08 PDT
I committed this fix.