Repurpose ActiveDOMObject::WillShowDialog to WillDeferLoading
All of the ActiveDOMObject ReasonForSuspensions are great, but only a *single* subclass does anything special for a particular Reason. And it's not WillShowDialog.
WillShowDialog is used whenever we defer page loading and has no special meaning beyond that.
We should rename it, then use it by default in all page load deferral cases without having to pass the argument around.
Noticed while exploring https://bugs.webkit.org/show_bug.cgi?id=84488
Created attachment 138199 [details]
Patch v1 - Do the rename and get rid of the unnecessary argument