Bug 84408 - REGRESSION(r114690): Broke GlueSerializeTest.BackwardsCompatibleTest in Chromium test_shell_tests (Requested by dimich on #webkit).
Summary: REGRESSION(r114690): Broke GlueSerializeTest.BackwardsCompatibleTest in Chrom...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 84385
  Show dependency treegraph
 
Reported: 2012-04-19 17:30 PDT by WebKit Review Bot
Modified: 2012-04-19 19:05 PDT (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r114690 (3.27 KB, patch)
2012-04-19 17:30 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-04-19 17:30:12 PDT
http://trac.webkit.org/changeset/114690 broke the build:
Broke GlueSerializeTest.BackwardsCompatibleTest in Chromium test_shell_tests (Requested by dimich on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-04-19 17:30:51 PDT
Created attachment 138014 [details]
ROLLOUT of r114690

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Dmitry Titov 2012-04-19 17:33:24 PDT
Comment on attachment 138014 [details]
ROLLOUT of r114690

Clearing flags on attachment: 138014

Committed r114703: <http://trac.webkit.org/changeset/114703>
Comment 3 Dmitry Titov 2012-04-19 17:33:29 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Dmitry Titov 2012-04-19 17:33:59 PDT
The failure:

[ RUN      ] GlueSerializeTest.BackwardsCompatibleTest
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
/b/build/slave/webkit-mac-latest-dbg/build/src/webkit/glue/glue_serialize_unittest.cc:118: Failure
Value of: b.pageScaleFactor()
  Actual: 0
Expected: a.pageScaleFactor()
Which is: 1
[  FAILED  ] GlueSerializeTest.BackwardsCompatibleTest (1 ms)
Comment 5 Alexandre Elias 2012-04-19 19:05:32 PDT
The problem was that the GlueSerializeTest was inadvertently relying on the default value.  I have a fix pending in https://chromiumcodereview.appspot.com/10153008