Bug 8437 - iExploder(#293): Crash in StringImpl::hash()
Summary: iExploder(#293): Crash in StringImpl::hash()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Java (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, Regression
: 8471 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-17 09:32 PDT by Alexey Proskuryakov
Modified: 2006-04-19 09:36 PDT (History)
2 users (show)

See Also:


Attachments
test case (15.80 KB, text/html)
2006-04-17 09:32 PDT, Alexey Proskuryakov
no flags Details
Reduced test case (35 bytes, text/html)
2006-04-17 10:00 PDT, mitz
no flags Details
Check and skip <param>s with empty name (2.01 KB, patch)
2006-04-17 10:28 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-04-17 09:32:00 PDT
run-iexploder-tests 293 (or just open the attached file).

Not sure if it's a kxmlcore bug, or RenderApplet::createWidgetIfNecessary() just passes invalid data.
Comment 1 Alexey Proskuryakov 2006-04-17 09:32:30 PDT
Created attachment 7763 [details]
test case
Comment 2 mitz 2006-04-17 10:00:00 PDT
Created attachment 7766 [details]
Reduced test case

This is the <applet> version of bug 6962.
Comment 3 mitz 2006-04-17 10:28:36 PDT
Created attachment 7768 [details]
Check and skip <param>s with empty name

Can't make an automated test since Java is disabled in DumpRenderTree.
Comment 4 Darin Adler 2006-04-17 13:10:08 PDT
Comment on attachment 7768 [details]
Check and skip <param>s with empty name

The issue is elements with no name (null String), not empty names (empty String). HashMap doesn't support null String as a key. But I suppose it's harmless to also omit elements with empty names.

r=me
Comment 5 Alexey Proskuryakov 2006-04-19 09:36:54 PDT
*** Bug 8471 has been marked as a duplicate of this bug. ***