Created attachment 137805 [details]
Comment on attachment 137805 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=137805&action=review
r=me, with a comment below:
> + shouldBe("safeGetter(a, b, c)", "" + safeGetter(checkA, b, c));
Would be nice to put in the actual values of b and c instead of the letters, so it's clearer what went wrong if something goes wrong.
> + shouldBe("getter(a, b, c)", "" + safeGetter(a, b));
Landed without Geoff suggestions in: http://trac.webkit.org/changeset/114587
Will land Geoff's suggestions in a separate patch.
Landed in http://trac.webkit.org/changeset/114594
Landed float64 test support in http://trac.webkit.org/changeset/114639