Bug 84216 - REGRESSION(r112177): Numbered list item rendered bulleted
: REGRESSION(r112177): Numbered list item rendered bulleted
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: Unspecified Unspecified
: P1 Normal
Assigned To:
: http://jsfiddle.net/FgdSB/7/
: InRadar, Regression
:
:
  Show dependency treegraph
 
Reported: 2012-04-17 17:33 PST by
Modified: 2012-04-19 17:09 PST (History)


Attachments
Patch (1.85 KB, patch)
2012-04-18 16:00 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff
Patch (5.08 KB, patch)
2012-04-18 18:08 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff
Patch (5.91 KB, patch)
2012-04-18 18:41 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-04 (6.06 MB, application/zip)
2012-04-18 19:41 PST, WebKit Review Bot
no flags Details
Patch (6.94 KB, patch)
2012-04-18 20:08 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-02 (6.22 MB, application/zip)
2012-04-18 22:40 PST, WebKit Review Bot
no flags Details
Patch (7.54 KB, patch)
2012-04-19 00:01 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff
Patch for landing (7.64 KB, patch)
2012-04-19 16:37 PST, David Barr
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-04-17 17:33:26 PST
What steps will reproduce the problem?
1. Create a <OL style="list-style-type: decimal;">
2. Append <LI> children with "list-style-position: outside;"

What is the expected result?
A numbered list item

What happens instead?
A bulleted list item

Confirmed with WebKit nightly, Version 5.1.5 (6534.55.3, r114368).
------- Comment #1 From 2012-04-17 17:52:07 PST -------
Ran bisect-builds:
Works: r112169  Fails: r112225
http://trac.webkit.org/log/trunk/?rev=112225&stop_rev=112170
------- Comment #2 From 2012-04-17 18:52:04 PST -------
Consistent with my first guess, manually narrowed to:
http://trac.webkit.org/changeset/112177

"cssText should use shorthand notations"
https://bugs.webkit.org/show_bug.cgi?id=81737
------- Comment #3 From 2012-04-17 20:52:31 PST -------
Also related:
http://trac.webkit.org/changeset/112321

"cssText should not generate literal 'initial' in shorthand properties"
https://bugs.webkit.org/show_bug.cgi?id=82364

Patching WebCore::StylePropertySet::getShorthandValue to return inherit or initial respectively:
list-style: inherit outside inherit;

Whereas, without that change the inspector displayed:
list-style: outside;
list-style-type: initial;
list-style-image: initial;

Could be a shorthand parsing issue.
------- Comment #4 From 2012-04-17 22:43:12 PST -------
<rdar://problem/11270257>
------- Comment #5 From 2012-04-17 22:57:05 PST -------
Apparently my change exposed an existing bug in parser :(
------- Comment #6 From 2012-04-18 15:23:03 PST -------
I've thought about it a bit more after discussing on IRC.
The cause appears to be that StylePropertySet::getShorthandValue()
is not bailing out when there are not enough longhand rules defined
to form a corresponding shortHand rule.
------- Comment #7 From 2012-04-18 16:00:27 PST -------
Created an attachment (id=137793) [details]
Patch

Uploading without new tests to determine test impact.
------- Comment #8 From 2012-04-18 16:06:02 PST -------
Attachment 137793 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/ChangeLog:8:  You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible.  [changelog/nonewtests] [5]
Total errors found: 1 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #9 From 2012-04-18 17:14:09 PST -------
Downstream bug report: http://crbug.com/122606
------- Comment #10 From 2012-04-18 18:08:38 PST -------
Created an attachment (id=137811) [details]
Patch

There is at least one shorthand that does not imply ommitted values, -webkit-transform-origin.
------- Comment #11 From 2012-04-18 18:41:51 PST -------
Created an attachment (id=137814) [details]
Patch

Updated css3/flexbox/css-properties.html
------- Comment #12 From 2012-04-18 19:40:46 PST -------
(From update of attachment 137814 [details])
Attachment 137814 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12437083

New failing tests:
fast/css/transform-inline-style.html
fast/css/uri-token-parsing.html
fast/css/transform-inline-style-remove.html
------- Comment #13 From 2012-04-18 19:41:03 PST -------
Created an attachment (id=137823) [details]
Archive of layout-test-results from ec2-cr-linux-04

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-04  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
------- Comment #14 From 2012-04-18 20:08:15 PST -------
Created an attachment (id=137827) [details]
Patch

Updated LayoutTests/fast/css/uri-token-parsing.html again. Expectations are embedded in the test, yuck.
------- Comment #15 From 2012-04-18 22:40:15 PST -------
(From update of attachment 137827 [details])
Attachment 137827 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12439113

New failing tests:
fast/css/transform-inline-style.html
fast/css/transform-inline-style-remove.html
------- Comment #16 From 2012-04-18 22:40:21 PST -------
Created an attachment (id=137839) [details]
Archive of layout-test-results from ec2-cr-linux-02

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
------- Comment #17 From 2012-04-19 00:01:34 PST -------
Created an attachment (id=137854) [details]
Patch
------- Comment #18 From 2012-04-19 16:25:55 PST -------
(From update of attachment 137854 [details])
r=me provided a comment is added as to why no test is added per IRC discussion.
------- Comment #19 From 2012-04-19 16:37:55 PST -------
Created an attachment (id=138007) [details]
Patch for landing
------- Comment #20 From 2012-04-19 17:08:40 PST -------
(From update of attachment 138007 [details])
Clearing flags on attachment: 138007

Committed r114699: <http://trac.webkit.org/changeset/114699>
------- Comment #21 From 2012-04-19 17:09:02 PST -------
All reviewed patches have been landed.  Closing bug.