Bug 83989 - AXRoleDescription for address element is incorrect
: AXRoleDescription for address element is incorrect
Status: RESOLVED DUPLICATE of bug 109013
: WebKit
Accessibility
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
: InRadar
:
:
  Show dependency treegraph
 
Reported: 2012-04-14 18:51 PST by
Modified: 2013-12-20 11:46 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-04-14 18:51:33 PST
The <address> element has an AXRoleDescription of "content information", which is the description for the "contentinfo" landmark role.

The "contentinfo" landmark role is for a "large perceivable region that contains information about the parent document...Within any document or application, the author SHOULD mark no more than one element with the contentinfo role." [http://www.w3.org/TR/wai-aria/roles#contentinfo]

The <address> element "represents the contact information for its nearest article or body element ancestor. If that is the body element, then the contact information applies to the document as a whole." [http://dev.w3.org/html5/spec/the-address-element.html]

While both the "contentinfo" landmark and <address> element represent meta-information about a parent element, the <address> element is specifically for contact information, relates only to its parent article or body element, and is not likely to be a "large perceivable region". It may occur multiple times within the parent document, in which case it does not relate to that parent document as a whole in the way the "contentinfo" landmark does. It is also likely that the <address> element will be nested in a <footer> element, which is similarly treated as a "contentinfo" landmark with a description of "content information". This would lead to one "content information" block being nested in another "content information" block.

To differentiate the <address> element's specific semantics from the more generic "contentinfo" landmark's semantics, it is recommended that AXRoleDescription for the <address> element be "address" instead of "content information".
------- Comment #1 From 2012-04-14 18:52:46 PST -------
Compare WebKit bug 78992 [https://bugs.webkit.org/show_bug.cgi?id=78992]
------- Comment #2 From 2013-10-25 10:58:19 PST -------
<rdar://problem/15321097>
------- Comment #3 From 2013-12-20 11:46:05 PST -------
Duping out to 109013

*** This bug has been marked as a duplicate of bug 109013 ***