Bug 8394 - Editable region does not accept dropped text if there is no selection
Summary: Editable region does not accept dropped text if there is no selection
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-14 13:52 PDT by mitz
Modified: 2006-04-19 02:25 PDT (History)
0 users

See Also:


Attachments
Patch (7.97 KB, patch)
2006-04-14 14:03 PDT, mitz
justin.garcia: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-04-14 13:52:34 PDT
Dropping plain text (or anything that should be converted into plain text) into an editable region or a text field fails if nothing is selected in the frame.

Even though it affects text fields now, it is not a regression, since previously text fields could not be dropped into unless they had focus (and therefore a selection).

I am going to attach a test case and a patch.
Comment 1 mitz 2006-04-14 14:03:28 PDT
Created attachment 7716 [details]
Patch