Bug 83572 - Height overflow when nesting multiple new Flexbox'es.
: Height overflow when nesting multiple new Flexbox'es.
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.6
: P2 Critical
Assigned To:
: http://jsfiddle.net/simurai/BQW3Y/
:
:
:
  Show dependency treegraph
 
Reported: 2012-04-10 05:59 PST by
Modified: 2012-05-03 16:21 PST (History)


Attachments
Patch (5.01 KB, patch)
2012-05-03 14:35 PST, Tony Chang
no flags Review Patch | Details | Formatted Diff | Diff
Patch for landing (6.46 KB, patch)
2012-05-03 14:56 PST, Tony Chang
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-04-10 05:59:48 PST
It appears that when nesting multiple "new" Flexbox'es, the total height of its flexible children are overflowing.

See: http://jsfiddle.net/simurai/BQW3Y/

Note: In the old Flexbox ( display: -webkit-box; ) it works fine.
------- Comment #1 From 2012-05-03 13:02:02 PST -------
*** Bug 85490 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2012-05-03 14:35:53 PST -------
Created an attachment (id=140094) [details]
Patch
------- Comment #3 From 2012-05-03 14:44:45 PST -------
(From update of attachment 140094 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=140094&action=review

> Source/WebCore/rendering/RenderFlexibleBox.cpp:606
> +        return overrideContentLogicalHeight - preferredMainAxisExtent;

Now that all return cases subtract preferredMainAxisExtent, I wonder if we should rename this method computeMainAxisExtent and subtract preferredMainAxisExtent in the one calling location.

Up to you.
------- Comment #4 From 2012-05-03 14:56:16 PST -------
Created an attachment (id=140101) [details]
Patch for landing
------- Comment #5 From 2012-05-03 14:57:24 PST -------
(In reply to comment #3)
> (From update of attachment 140094 [details] [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=140094&action=review
> 
> > Source/WebCore/rendering/RenderFlexibleBox.cpp:606
> > +        return overrideContentLogicalHeight - preferredMainAxisExtent;
> 
> Now that all return cases subtract preferredMainAxisExtent, I wonder if we should rename this method computeMainAxisExtent and subtract preferredMainAxisExtent in the one calling location.

I did a variation that subtracts preferredMainAxisExtent at the end of the method.  It's convenient that the concept of available free space is a function.
------- Comment #6 From 2012-05-03 16:21:01 PST -------
(From update of attachment 140101 [details])
Clearing flags on attachment: 140101

Committed r116038: <http://trac.webkit.org/changeset/116038>
------- Comment #7 From 2012-05-03 16:21:10 PST -------
All reviewed patches have been landed.  Closing bug.