Bug 83256 - Limit -apple- and -khtml- to ENABLE(LEGACY_CSS_VENDOR_PREFIXES)
Summary: Limit -apple- and -khtml- to ENABLE(LEGACY_CSS_VENDOR_PREFIXES)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
: 42093 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-05 00:54 PDT by Adam Barth
Modified: 2012-04-25 09:53 PDT (History)
13 users (show)

See Also:


Attachments
Patch (1.83 KB, patch)
2012-04-05 00:58 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
does not compile (10.48 KB, patch)
2012-04-06 16:23 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (14.39 KB, patch)
2012-04-06 16:57 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-04 (6.56 MB, application/zip)
2012-04-09 02:47 PDT, WebKit Review Bot
no flags Details
Archive of layout-test-results from ec2-cr-linux-01 (6.44 MB, application/zip)
2012-04-09 04:03 PDT, WebKit Review Bot
no flags Details
Patch for landing (17.55 KB, patch)
2012-04-09 23:41 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch for landing (17.85 KB, patch)
2012-04-10 13:48 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2012-04-05 00:54:57 PDT
Limit -apple- and -khtml- to ENABLE(DASHBOARD_SUPPORT)
Comment 1 Adam Barth 2012-04-05 00:58:45 PDT
Created attachment 135774 [details]
Patch
Comment 2 Benjamin Poulain 2012-04-05 12:22:15 PDT
Comment on attachment 135774 [details]
Patch

You should also update the JavaScript bindings for consistency (JSCSSStyleDeclarationCustom.cpp && V8CSSStyleDeclarationCustom.cpp.)
Comment 3 Adam Barth 2012-04-06 16:23:22 PDT
Created attachment 136093 [details]
does not compile
Comment 4 Benjamin Poulain 2012-04-06 16:42:30 PDT
Note that cssPropertyID() is also performance sensitive because of animations driven by JavaScript. I think a flag is not a bad idea if the other option is adding branches.
Comment 5 Adam Barth 2012-04-06 16:57:09 PDT
Created attachment 136099 [details]
Patch
Comment 6 WebKit Review Bot 2012-04-09 02:47:06 PDT
Comment on attachment 136099 [details]
Patch

Attachment 136099 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12370125

New failing tests:
inspector/styles/vendor-prefixes.html
fast/css/apple-prefix.html
Comment 7 WebKit Review Bot 2012-04-09 02:47:14 PDT
Created attachment 136204 [details]
Archive of layout-test-results from ec2-cr-linux-04

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-04  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 8 WebKit Review Bot 2012-04-09 04:03:53 PDT
Comment on attachment 136099 [details]
Patch

Attachment 136099 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12368167

New failing tests:
inspector/styles/vendor-prefixes.html
fast/css/apple-prefix.html
Comment 9 WebKit Review Bot 2012-04-09 04:03:59 PDT
Created attachment 136210 [details]
Archive of layout-test-results from ec2-cr-linux-01

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-01  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 10 Eric Seidel 2012-04-09 21:59:03 PDT
Comment on attachment 136099 [details]
Patch

LGTM, and we haven't heard any further objections.  You'll need to update the test results for chromium.
Comment 11 Adam Barth 2012-04-09 23:41:40 PDT
Created attachment 136407 [details]
Patch for landing
Comment 12 WebKit Review Bot 2012-04-10 12:33:50 PDT
Comment on attachment 136407 [details]
Patch for landing

Rejecting attachment 136407 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
um/test_expectations.txt
patching file LayoutTests/platform/efl/Skipped
Hunk #1 succeeded at 2637 (offset -18 lines).
patching file LayoutTests/platform/gtk/Skipped
Hunk #1 FAILED at 1640.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/gtk/Skipped.rej
patching file LayoutTests/platform/qt/Skipped
Hunk #1 succeeded at 2586 (offset 6 lines).

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 1 cwd: /mnt/git/webkit-commit-queue/

Full output: http://queues.webkit.org/results/12380446
Comment 13 Adam Barth 2012-04-10 13:48:42 PDT
Created attachment 136529 [details]
Patch for landing
Comment 14 WebKit Review Bot 2012-04-10 17:18:02 PDT
Comment on attachment 136529 [details]
Patch for landing

Clearing flags on attachment: 136529

Committed r113795: <http://trac.webkit.org/changeset/113795>
Comment 15 WebKit Review Bot 2012-04-10 17:18:25 PDT
All reviewed patches have been landed.  Closing bug.
Comment 16 Joseph Pecoraro 2012-04-18 17:06:59 PDT
Comment on attachment 136529 [details]
Patch for landing

View in context: https://bugs.webkit.org/attachment.cgi?id=136529&action=review

> Source/WebCore/Configurations/FeatureDefines.xcconfig:88
>  ENABLE_JAVASCRIPT_DEBUGGER = ENABLE_JAVASCRIPT_DEBUGGER;
> +ENABLE_LEGACY_CSS_VENDOR_PREFIXES = ENABLE_LEGACY_CSS_VENDOR_PREFIXES;
>  ENABLE_LEGACY_NOTIFICATIONS = ENABLE_LEGACY_NOTIFICATIONS;

As a heads up, the FeatureDefines.xcconfig file across components JavaScriptCore / WebCore / WebKit / WebKit2  should be kept identical. I don't see that written down anywhere though.
Comment 17 Benjamin Poulain 2012-04-18 17:13:45 PDT
> As a heads up, the FeatureDefines.xcconfig file across components JavaScriptCore / WebCore / WebKit / WebKit2  should be kept identical. I don't see that written down anywhere though.

That is kinda documented: http://trac.webkit.org/wiki/AddingFeatures
Comment 18 Alexey Proskuryakov 2012-04-25 09:53:19 PDT
*** Bug 42093 has been marked as a duplicate of this bug. ***