Bug 83173 - Layout Test http/tests/websocket/tests/hybi/workers/worker-reload.html is flaky
Summary: Layout Test http/tests/websocket/tests/hybi/workers/worker-reload.html is flaky
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yuta Kitamura
URL:
Keywords:
: 83124 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-04 09:56 PDT by Dimitri Glazkov (Google)
Modified: 2012-04-12 03:07 PDT (History)
4 users (show)

See Also:


Attachments
Patch (2.37 KB, patch)
2012-04-04 18:53 PDT, Yuta Kitamura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Yuta Kitamura 2012-04-04 18:01:26 PDT
Hm, it looks like reloading is not as fast as I expected in Debug builds. I think I just need to adjust parameters.
Comment 2 Yuta Kitamura 2012-04-04 18:06:22 PDT
*** Bug 83124 has been marked as a duplicate of this bug. ***
Comment 3 Yuta Kitamura 2012-04-04 18:38:26 PDT
(And I was mildly surprised at the fact that Chromium's DumpRenderTree now supports dedicated workers)
Comment 4 Yuta Kitamura 2012-04-04 18:53:52 PDT
Created attachment 135742 [details]
Patch
Comment 5 David Levin 2012-04-04 21:44:19 PDT
(In reply to comment #3)
> (And I was mildly surprised at the fact that Chromium's DumpRenderTree now supports dedicated workers)

Awesome. Isn't it? (Thanks to Mitya.)
Comment 6 Yuta Kitamura 2012-04-04 21:57:32 PDT
(In reply to comment #5)
> (In reply to comment #3)
> > (And I was mildly surprised at the fact that Chromium's DumpRenderTree now supports dedicated workers)
> 
> Awesome. Isn't it? (Thanks to Mitya.)

Yes, indeed.
Comment 7 WebKit Review Bot 2012-04-04 22:17:33 PDT
Comment on attachment 135742 [details]
Patch

Clearing flags on attachment: 135742

Committed r113292: <http://trac.webkit.org/changeset/113292>
Comment 8 WebKit Review Bot 2012-04-04 22:17:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Yuta Kitamura 2012-04-12 03:07:07 PDT
This test is no longer flaky.

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=worker-reload.html

I'm going to update the test expectations.