These APIs are defined to be integers, so we should use the actual rendered integers when returning values to JS.
Created attachment 135550 [details] Patch
Comment on attachment 135550 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=135550&action=review > Source/WebCore/dom/Element.cpp:351 > if (RenderBoxModelObject* rend = renderBoxModelObject()) Let's remove those abreviations (not repeated on all the other changes) while at it: renderBoxModelObject would be my favorite but at least renderer would be OK. (note that also most of this logic could use const RenderObject's but that's another - definitely bug-worthy - story)
Comment on attachment 135550 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=135550&action=review >> Source/WebCore/dom/Element.cpp:351 >> if (RenderBoxModelObject* rend = renderBoxModelObject()) > > Let's remove those abreviations (not repeated on all the other changes) while at it: renderBoxModelObject would be my favorite but at least renderer would be OK. > > (note that also most of this logic could use const RenderObject's but that's another - definitely bug-worthy - story) Done and done! Good point and thanks for the review :)
Created attachment 135804 [details] Patch for landing
Comment on attachment 135804 [details] Patch for landing Clearing flags on attachment: 135804 Committed r113317: <http://trac.webkit.org/changeset/113317>
All reviewed patches have been landed. Closing bug.