Page loading status API lacks a status for intentionally stopped loading
Created attachment 135411 [details]
Comment on attachment 135411 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=135411&action=review
> + is set to the new state LoadStoppedStatus. This reflects reality more accuratelly,
typo : accurately
> + for the page was not fully loaded (a LoadSucceededStatus), and it wasn't an unexpected
The english has some issue here.
Created attachment 135422 [details]
Marcelo: I think would be nice to have API tests for this. :-)
Simon, Tor-Arne: what do you think of this new status?
Comment on attachment 135422 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=135422&action=review
> +void QQuickWebViewPrivate::loadDidStopped()
This is a frankenstein of WebKit/Apple and Qt naming convention (did + 'ed) :)
I prefer we keep the Qt one here, loadStopped. Either that or loadDidStop.
Created attachment 163168 [details]
Comment on attachment 163168 [details]
Clearing flags on attachment: 163168
Committed r128177: <http://trac.webkit.org/changeset/128177>
All reviewed patches have been landed. Closing bug.