Bug 82898 - -webkit-transform set to an element makes other unrelated elements' text thinner
Summary: -webkit-transform set to an element makes other unrelated elements' text thinner
Status: RESOLVED DUPLICATE of bug 23364
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.7
: P2 Minor
Assignee: Nobody
URL: http://mikrobill.com
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-02 07:36 PDT by Max Izmailov
Modified: 2012-04-02 15:55 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Izmailov 2012-04-02 07:36:24 PDT
We've noticed that when you switch between HP and other pages on http://mikrobill.com (not only) header menu text changes its appearance. On the HP it is thinner than on other pages.

It turns out that if I disable the following rule everything goes back to normal:

  #showcase #screenshots img {
    -webkit-transform: perspective(600px) rotateY(-4deg);
  }

I tried to apply this rule to other elements and play with values, but even perspective(0px) rotateY(0deg) produces the same result: totally unrelated element's text renders thinner that it must be.

Tested in Chrome 18.0.1025.142 and in nightly 5.1.5 (7534.55.3, r112532). Results are the same.

HP (thinner text): http://i39.tinypic.com/2cdx28m.png
Another page: http://i43.tinypic.com/2ih2gk7.png
Comment 1 Alexey Proskuryakov 2012-04-02 15:55:02 PDT

*** This bug has been marked as a duplicate of bug 23364 ***