RESOLVED FIXED 82877
[GTK] Fix names of failed unit tests in Tools/Scripts/run-gtk-tests
https://bugs.webkit.org/show_bug.cgi?id=82877
Summary [GTK] Fix names of failed unit tests in Tools/Scripts/run-gtk-tests
Carlos Garcia Campos
Reported 2012-04-02 03:36:01 PDT
The method lstrip is incorrectly used to get the name of failed tests from the full path.
Attachments
Patch (1.18 KB, patch)
2012-04-02 03:39 PDT, Carlos Garcia Campos
no flags
Carlos Garcia Campos
Comment 1 2012-04-02 03:39:50 PDT
Philippe Normand
Comment 2 2012-04-02 03:45:05 PDT
Comment on attachment 135058 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=135058&action=review > Tools/Scripts/run-gtk-tests:268 > + names = [test.replace(self._programs_path, '', 1) for test in failed_tests] What about os.path.basename(test) ?
Carlos Garcia Campos
Comment 3 2012-04-02 03:47:46 PDT
(In reply to comment #2) > (From update of attachment 135058 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=135058&action=review > > > Tools/Scripts/run-gtk-tests:268 > > + names = [test.replace(self._programs_path, '', 1) for test in failed_tests] > > What about os.path.basename(test) ? that would give you the name, but we also want the directory unittests/WebKit2APITests
Philippe Normand
Comment 4 2012-04-02 03:52:35 PDT
(In reply to comment #3) > (In reply to comment #2) > > (From update of attachment 135058 [details] [details]) > > View in context: https://bugs.webkit.org/attachment.cgi?id=135058&action=review > > > > > Tools/Scripts/run-gtk-tests:268 > > > + names = [test.replace(self._programs_path, '', 1) for test in failed_tests] > > > > What about os.path.basename(test) ? > > that would give you the name, but we also want the directory unittests/WebKit2APITests Is it really useful? The test naming conventions differ between WK1 and WK2
Carlos Garcia Campos
Comment 5 2012-04-02 03:54:52 PDT
(In reply to comment #4) > (In reply to comment #3) > > (In reply to comment #2) > > > (From update of attachment 135058 [details] [details] [details]) > > > View in context: https://bugs.webkit.org/attachment.cgi?id=135058&action=review > > > > > > > Tools/Scripts/run-gtk-tests:268 > > > > + names = [test.replace(self._programs_path, '', 1) for test in failed_tests] > > > > > > What about os.path.basename(test) ? > > > > that would give you the name, but we also want the directory unittests/WebKit2APITests > > Is it really useful? > The test naming conventions differ between WK1 and WK2 That's how we refer to tests, see SkippedTest class
Carlos Garcia Campos
Comment 6 2012-04-02 04:07:19 PDT
Note You need to log in before you can comment on or make changes to this bug.