Bug 82853 - [GTK] Add filesystem API interface
Summary: [GTK] Add filesystem API interface
Status: RESOLVED DUPLICATE of bug 58443
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 58443
  Show dependency treegraph
 
Reported: 2012-04-01 21:46 PDT by ChangSeok Oh
Modified: 2012-04-05 16:42 PDT (History)
4 users (show)

See Also:


Attachments
Patch (37.04 KB, patch)
2012-04-03 08:09 PDT, ChangSeok Oh
gns: review-
gns: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ChangSeok Oh 2012-04-01 21:46:32 PDT
I'll add file system api interface for gtk port in here.
Comment 1 ChangSeok Oh 2012-04-03 08:09:35 PDT
Created attachment 135330 [details]
Patch
Comment 2 Gustavo Noronha (kov) 2012-04-03 09:43:21 PDT
Comment on attachment 135330 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=135330&action=review

I am not sure I understand the rationale for creating these new classes? What problem are we trying to solve here? I don't like these empty shells tbh, I'd rather have implementation of stuff in the patches, it makes it way easier to understand what's intended, what's being solved and so on.

> Source/WebCore/ChangeLog:24
> +        * platform/gtk/AsyncFileSystemCallbacksGtk.cpp: Added. This is an implement of AsyncFileSystemCallbacks.

implement -> implementation
Comment 3 ChangSeok Oh 2012-04-03 19:24:37 PDT
(In reply to comment #2)
> (From update of attachment 135330 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=135330&action=review
> 
> I am not sure I understand the rationale for creating these new classes? What problem are we trying to solve here? I don't like these empty shells tbh, I'd rather have implementation of stuff in the patches, it makes it way easier to understand what's intended, what's being solved and so on.
> 
> > Source/WebCore/ChangeLog:24
> > +        * platform/gtk/AsyncFileSystemCallbacksGtk.cpp: Added. This is an implement of AsyncFileSystemCallbacks.
> 
> implement -> implementation

Thanks for the review.
I think it's better to split the patch into some parts, since the full patch is too huge to understand.
Well, if you don't mind, I'm willing to submit the full patch again.
Comment 4 Gustavo Noronha (kov) 2012-04-05 16:42:14 PDT

*** This bug has been marked as a duplicate of bug 58443 ***