Bug 82777 - Subpixel antialiasing missing in some elements that overlay a graphics accelerated element
Summary: Subpixel antialiasing missing in some elements that overlay a graphics accele...
Status: RESOLVED DUPLICATE of bug 23364
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 14:02 PDT by Tim Ehat
Modified: 2013-11-08 17:52 PST (History)
1 user (show)

See Also:


Attachments
Example file (693 bytes, text/html)
2012-03-30 14:02 PDT, Tim Ehat
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Ehat 2012-03-30 14:02:41 PDT
Created attachment 134875 [details]
Example file

In the attached example, the <h1> ("Page Title") tag is graphics-accelerated ("-webkit-transform: transform3d(0,0,0)").  The dialog <div> overlaps the <h1> tag (made visible with an semi-transparent background).  The text inside the <h2> tag (which is inside the dialog <div>) does not have any sub-pixel font smoothing.

Adding a background-color to the <h2> tag will enable sub-pixel antialiasing again.  It seems this shouldn't be necessary since the "dialog-content" <div> already has an opaque background color.

Changing the "top: 5%" to "top: 15%" (maybe higher, depending on window size...) on the "dialog" <div> will also re-enable sub-pixel antialiasing (since that div will no longer overlay the graphics-accelerated <h1> tag.


Seeing this in Safari on Mac OS X Snow Leopard [Version 5.1.4 (6534.54.16)], Chrome on Mac OS X Snow Leopard [17.0.963.83], Chrome on Windows 7 [18.0.1025.142 m].
Comment 1 Simon Fraser (smfr) 2013-11-08 17:52:53 PST

*** This bug has been marked as a duplicate of bug 23364 ***