Bug 82715 - keycode is always 0 when using non-Latin keyboard layout.
Summary: keycode is always 0 when using non-Latin keyboard layout.
Status: RESOLVED DUPLICATE of bug 77473
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 03:52 PDT by Yuriy Brayko
Modified: 2012-03-30 10:19 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuriy Brayko 2012-03-30 03:52:23 PDT
What steps will reproduce the problem?
1. Open http://unixpapa.com/js/testkey.html in Safari
2. Switch to a non-Latin keyboard layout, eg. Russian, Arabic.
3. Press some keys.

What is the expected output? What do you see instead?
keyCode value of key events should not be zero, but they are always zero when using non-Latin keyboard layout.
Comment 1 Alexey Proskuryakov 2012-03-30 10:19:16 PDT
This should have been fixed a while ago. Are you testing with a nightly build from <http://nightly.webkit.org/>?

*** This bug has been marked as a duplicate of bug 77473 ***