Bug 82129 - REGRESSION (r110065-r110080): Content drawing outside overflow: hidden at ynet.co.il
Summary: REGRESSION (r110065-r110080): Content drawing outside overflow: hidden at yne...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Julien Chaffraix
URL: http://ynet.co.il/
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2012-03-24 11:06 PDT by mitz
Modified: 2012-03-30 10:29 PDT (History)
7 users (show)

See Also:


Attachments
Reduction (190 bytes, text/html)
2012-03-24 11:45 PDT, mitz
no flags Details
Proposed fix: move the ensureLayer() before removing before and start overflow. (13.76 KB, patch)
2012-03-26 09:47 PDT, Julien Chaffraix
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-02 (9.68 MB, application/zip)
2012-03-26 10:23 PDT, WebKit Review Bot
no flags Details
Added the missing rebaseline. Dan, I would love your comment on whether the tests will be skipped on WK2. (26.41 KB, patch)
2012-03-28 10:42 PDT, Julien Chaffraix
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2012-03-24 11:06:22 PDT
To reproduce, navigate to the URL and start scrolling the page down. In the sidebar on the right hand side, there are several boxes with blue headers, each showing three video thumbnails. After r110080, three additional thumbnails are rendered outside the box, to its left, overlapping other page content. This should not happen, as the boxes specify overflow: hidden.

This was most likely caused by <http://trac.webkit.org/r110072>, the fix for bug 75568.
Comment 1 mitz 2012-03-24 11:08:03 PDT
<rdar://problem/11115138>
Comment 2 mitz 2012-03-24 11:13:04 PDT
Julien, please consider reverting r110072 if you cannot come up with a fix for this bug and for bug 81802 soon.
Comment 3 mitz 2012-03-24 11:45:22 PDT
Created attachment 133645 [details]
Reduction
Comment 4 Julien Chaffraix 2012-03-26 09:47:53 PDT
Created attachment 133836 [details]
Proposed fix: move the ensureLayer() before removing before and start overflow.
Comment 5 WebKit Review Bot 2012-03-26 10:23:07 PDT
Comment on attachment 133836 [details]
Proposed fix: move the ensureLayer() before removing before and start overflow.

Attachment 133836 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12134910

New failing tests:
fast/block/lineboxcontain/block-font.html
fast/block/lineboxcontain/font.html
fast/block/lineboxcontain/block-glyphs.html
Comment 6 WebKit Review Bot 2012-03-26 10:23:14 PDT
Created attachment 133841 [details]
Archive of layout-test-results from ec2-cr-linux-02

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 7 Julien Chaffraix 2012-03-28 10:42:13 PDT
Created attachment 134332 [details]
Added the missing rebaseline. Dan, I would love your comment on whether the tests will be skipped on WK2.
Comment 8 Julien Chaffraix 2012-03-29 14:57:28 PDT
Comment on attachment 134332 [details]
Added the missing rebaseline. Dan, I would love your comment on whether the tests will be skipped on WK2.

Manually landed the fix in http://trac.webkit.org/changeset/112582. Thanks Ojan and Dan for the reviews.
Comment 9 Simon Fraser (smfr) 2012-03-30 10:29:45 PDT
See also bug 82742.