Bug 82120 - Supersede t1504-c543-txt-decor-00-d-g.html with c543-txt-decor-000.html
: Supersede t1504-c543-txt-decor-00-d-g.html with c543-txt-decor-000.html
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-03-24 01:06 PST by
Modified: 2012-03-26 10:36 PST (History)


Attachments
Patch (110.36 KB, patch)
2012-03-24 01:06 PST, SravanKumar S(:sravan)
pfeldman: review-
Review Patch | Details | Formatted Diff | Diff
Patch (103.54 KB, patch)
2012-03-26 00:38 PST, SravanKumar S(:sravan)
pfeldman: review-
webkit.review.bot: commit‑queue-
Review Patch | Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-02 (9.69 MB, application/zip)
2012-03-26 01:12 PST, WebKit Review Bot
no flags Details
patch (104.48 KB, patch)
2012-03-26 03:18 PST, SravanKumar S(:sravan)
no flags Review Patch | Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-03 (9.76 MB, application/zip)
2012-03-26 03:57 PST, WebKit Review Bot
no flags Details
Archive of layout-test-results from ec2-cq-02 (9.76 MB, application/zip)
2012-03-26 08:56 PST, WebKit Review Bot
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-24 01:06:58 PST
Created an attachment (id=133623) [details]
Patch

In follow up to Bug:61699.
As webkit has got a policy to add a new bug for a new test.

Brief Description:

There are Multiple failures in css2.1/t1504-c543-txt-decor-00-d-g.html, this has been corrected in css test suite and text decorations got changed. Following are the links to confirm,

http://lists.w3.org/Archives/Public/public-css-testsuite/2010Jan/0032.html
http://test.csswg.org/suites/css2.1/20110323/html4/c543-txt-decor-000.htm

So, just superseding t1504-c543-txt-decor-00-d-g.html with c543-txt-decor-000.html.
------- Comment #1 From 2012-03-24 03:37:42 PST -------
(From update of attachment 133623 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=133623&action=review

> LayoutTests/css2.1/20110323/c543-txt-decor-000.html:1
> +<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

I dont' see expectations for non-win platforms.

> LayoutTests/platform/chromium/test_expectations.txt:1064
> +BUGWK61699 : css2.1/20110323/c543-txt-decor-000.html = IMAGE IMAGE+TEXT

Please do not add it here - WebKit sheriff will do that for you.
------- Comment #2 From 2012-03-25 22:43:07 PST -------
Thanks for the review, as i have only windows machine with me, i think you are asking me to add these entries in test_expectations.txt of individual ports.
Will do that and will upload the patch again.
------- Comment #3 From 2012-03-25 22:47:33 PST -------
(In reply to comment #2)
> Thanks for the review, as i have only windows machine with me, i think you are asking me to add these entries in test_expectations.txt of individual ports.
> Will do that and will upload the patch again.

No. You should not touch test_expectations. You should generate base expectations (applied to all ports) that will satisfy the main WebKit builders. Other port owners will generate baselines for their ports. My concern is that you are adding expectations to platform/win, while you should be adding them beside the test itself.
------- Comment #4 From 2012-03-26 00:38:58 PST -------
Created an attachment (id=133742) [details]
Patch

Patch, generated base expectations on MAC.
------- Comment #5 From 2012-03-26 01:12:48 PST -------
(From update of attachment 133742 [details])
Attachment 133742 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12132652

New failing tests:
css2.1/20110323/c543-txt-decor-000.html
------- Comment #6 From 2012-03-26 01:12:56 PST -------
Created an attachment (id=133745) [details]
Archive of layout-test-results from ec2-cr-linux-02

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
------- Comment #7 From 2012-03-26 01:40:11 PST -------
(From update of attachment 133742 [details])
The last bullet "There should be a long blue underline between here and here" seems to be rendered poorly. Any idea on what is wrong? Is it test or implementation?
------- Comment #8 From 2012-03-26 01:44:00 PST -------
(From update of attachment 133742 [details])
As per comment #7 r-, we should not land tests with misleading expectations.
------- Comment #9 From 2012-03-26 03:18:18 PST -------
Created an attachment (id=133762) [details]
patch

Patch with correct test case.
------- Comment #10 From 2012-03-26 03:57:05 PST -------
(From update of attachment 133762 [details])
Attachment 133762 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/12132720

New failing tests:
css2.1/20110323/c543-txt-decor-000.html
------- Comment #11 From 2012-03-26 03:57:13 PST -------
Created an attachment (id=133768) [details]
Archive of layout-test-results from ec2-cr-linux-03

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-03  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
------- Comment #12 From 2012-03-26 08:56:41 PST -------
(From update of attachment 133762 [details])
Rejecting attachment 133762 [details] from commit-queue.

New failing tests:
css2.1/20110323/c543-txt-decor-000.html
Full output: http://queues.webkit.org/results/12132849
------- Comment #13 From 2012-03-26 08:56:49 PST -------
Created an attachment (id=133823) [details]
Archive of layout-test-results from ec2-cq-02

The attached test failures were seen while running run-webkit-tests on the commit-queue.
Bot: ec2-cq-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
------- Comment #14 From 2012-03-26 09:43:47 PST -------
(From update of attachment 133762 [details])
Clearing flags on attachment: 133762

Committed r112112: <http://trac.webkit.org/changeset/112112>
------- Comment #15 From 2012-03-26 09:46:09 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #16 From 2012-03-26 10:36:25 PST -------
*** Bug 61699 has been marked as a duplicate of this bug. ***