Bug 8203 - REGRESSION: "Invite a friend" text field in GMail page spills out of table
Summary: REGRESSION: "Invite a friend" text field in GMail page spills out of table
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Beth Dakin
URL:
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-04-05 17:12 PDT by Adele Peterson
Modified: 2006-04-06 11:43 PDT (History)
2 users (show)

See Also:


Attachments
test case - reduction (192 bytes, text/html)
2006-04-05 17:13 PDT, Adele Peterson
no flags Details
m_minWidth should be 0 for percents (769 bytes, patch)
2006-04-06 11:16 PDT, Beth Dakin
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-04-05 17:12:18 PDT
"Invite a friend" text field in GMail page spills out of table

Reduction attached.
Comment 1 Adele Peterson 2006-04-05 17:13:12 PDT
Created attachment 7533 [details]
test case - reduction
Comment 2 Adele Peterson 2006-04-05 17:18:42 PDT
I think width:100% might not be doing what its supposed to do here.
Comment 3 Adele Peterson 2006-04-05 17:19:52 PDT
Note- the text field (in the reduction, and the live site) looks the right width in Firefox and in stock Safari.
Comment 4 Beth Dakin 2006-04-06 10:15:52 PDT
I think I have a fix for this...
Comment 5 Beth Dakin 2006-04-06 11:16:59 PDT
Created attachment 7540 [details]
m_minWidth should be 0 for percents

Here is the patch that fixes the test case. RenderReplaced::calcMinMaxWidth() sets m_minWidth to 0 when the width is a percent, so this patch copies that behavior into RenderTextField::calcMinMaxWidth(). This causes two layout tests to have different layout, but Hyatt thinks the new layout is more correct.
Comment 6 Darin Adler 2006-04-06 11:19:28 PDT
Comment on attachment 7540 [details]
m_minWidth should be 0 for percents

Sweet! Since Hyatt approves the concept, I definitely approve the patch. r=me
Comment 7 Beth Dakin 2006-04-06 11:43:08 PDT
I committed the fix.