The notion that some flags are "ArithNodeFlags" is mostly antiquated.
The renaming from NodeUse to Edge messed up some node flags names (NodeUsedAsNum become EdgedAsNum ... ooops).
It appears that we have a method called setArithNodeFlag() which is never called.
It appears that we have both mergeArithNodeFlags and mergeFlags. The former has some assertions, which may be useful - but it's sad that we have two methods that really do the same thing.
Created attachment 133368 [details]
Landed in http://trac.webkit.org/changeset/111781