Bug 81877 - [Qt] Add full platforms to Qt buildslaves
Summary: [Qt] Add full platforms to Qt buildslaves
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Csaba Osztrogonác
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2012-03-22 00:25 PDT by Csaba Osztrogonác
Modified: 2012-03-22 09:58 PDT (History)
7 users (show)

See Also:


Attachments
Patch (5.77 KB, patch)
2012-03-22 00:32 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-03-22 00:25:46 PDT
It is necessary to make Qt WK2 perf bot happier.

The problem is that the full platform is the uniqe key on 
the perf appspot to save the results from perf buildslaves.
(I think the builder name would be better.) But unfortunately
full platform is simple "qt" for all Qt buildslave. It isn't
good, it should be fixed. This fix won't break anything else,
because only perf test uses the full platform.
Comment 1 Csaba Osztrogonác 2012-03-22 00:32:01 PDT
Created attachment 133199 [details]
Patch
Comment 2 Csaba Osztrogonác 2012-03-22 00:35:51 PDT
Comment on attachment 133199 [details]
Patch

cq-, I'd like to land it manually and watch the bots to ensure not break anything
Comment 3 Ryosuke Niwa 2012-03-22 00:36:47 PDT
Comment on attachment 133199 [details]
Patch

As long as it can build & run tests.
Comment 4 Csaba Osztrogonác 2012-03-22 00:51:18 PDT
Comment on attachment 133199 [details]
Patch

Clearing flags on attachment: 133199

Committed r111658: <http://trac.webkit.org/changeset/111658>
Comment 5 Csaba Osztrogonác 2012-03-22 00:51:26 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Csaba Osztrogonác 2012-03-22 01:02:07 PDT
Lucas, could you restart/reconfigure the master due to this change, please?
It seems automatic reconfigure after master.cfg change doesn't work now.
Have you got any idea why?
Comment 7 Lucas Forschler 2012-03-22 09:25:29 PDT
I've kicked off a reconfig.  Please let me know if it is not as you expected.
Comment 8 Csaba Osztrogonác 2012-03-22 09:34:03 PDT
(In reply to comment #7)
> I've kicked off a reconfig.  Please let me know if it is not as you expected.

It seems it didn't help. :( fullplatform on Qt slaves are still "qt" instead of the right fullplatform.
Comment 9 Csaba Osztrogonác 2012-03-22 09:51:39 PDT
Maybe a restart would help. It seems build.webkit.org is so sick now, there are 292 and 28 stucked build for SL builders, 197 stucked build for win builder.
Comment 10 Lucas Forschler 2012-03-22 09:56:28 PDT
just kicked off a restart.  Hope that does the trick.
Comment 11 Csaba Osztrogonác 2012-03-22 09:58:09 PDT
Yes, now fullplatform is OK, many thanks.