Bug 81860 - [Chromium] Should check m_socket in SocketStreamHandleInternal::close()
Summary: [Chromium] Should check m_socket in SocketStreamHandleInternal::close()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kenichi Ishibashi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 18:21 PDT by Kenichi Ishibashi
Modified: 2012-03-22 00:26 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.49 KB, patch)
2012-03-21 18:26 PDT, Kenichi Ishibashi
no flags Details | Formatted Diff | Diff
Patch (1.71 KB, patch)
2012-03-21 23:14 PDT, Kenichi Ishibashi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenichi Ishibashi 2012-03-21 18:21:44 PDT
See the chromium bug report: http://crbug.com/118846

This problem not always occurs (maybe depends on server implementation).
Comment 1 Kenichi Ishibashi 2012-03-21 18:26:10 PDT
Created attachment 133161 [details]
Patch
Comment 2 Kenichi Ishibashi 2012-03-21 18:29:44 PDT
(In reply to comment #1)
> Created an attachment (id=133161) [details]
> Patch

This patch doesn't include test because user interaction (closing alert popup) is needed to reproduce the problem.
Comment 3 Kent Tamura 2012-03-21 20:06:41 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=133161) [details] [details]
> > Patch
> 
> This patch doesn't include test because user interaction (closing alert popup) is needed to reproduce the problem.

Would you add reasons why m_socket can be 0 and why alert() affects to ChangeLog?
Comment 4 Kenichi Ishibashi 2012-03-21 23:14:49 PDT
Created attachment 133192 [details]
Patch
Comment 5 Kenichi Ishibashi 2012-03-21 23:15:52 PDT
> Would you add reasons why m_socket can be 0 and why alert() affects to ChangeLog?

Thank you for review. Added explanations to ChangeLog.
Comment 6 Kent Tamura 2012-03-21 23:26:11 PDT
Comment on attachment 133192 [details]
Patch

ok
Comment 7 WebKit Review Bot 2012-03-22 00:26:02 PDT
Comment on attachment 133192 [details]
Patch

Clearing flags on attachment: 133192

Committed r111656: <http://trac.webkit.org/changeset/111656>
Comment 8 WebKit Review Bot 2012-03-22 00:26:06 PDT
All reviewed patches have been landed.  Closing bug.