Bug 8181 - REGRESSION: After tabbing in page's field, attempting to tab from Google toolbar search to page fails on first try
Summary: REGRESSION: After tabbing in page's field, attempting to tab from Google tool...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-04-04 10:04 PDT by Chris Petersen
Modified: 2006-04-21 23:02 PDT (History)
0 users

See Also:


Attachments
Input test (237 bytes, text/html)
2006-04-04 10:07 PDT, Chris Petersen
no flags Details
patch (1.15 KB, patch)
2006-04-21 22:42 PDT, Adele Peterson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2006-04-04 10:04:51 PDT
* SUMMARY
After tabbing between input fields on a page, placing focus in Google toolbar search field and pressing tab key fails to place focus in input field on page. This only fails on the first attempt since pressing Tab key again places focus in input field on page.

* STEPS TO REPRODUCE
1. With TOT Webkit, open test case "input_test.html"
2. Place focus in Field 1 and press Tab key. This should place focus in Field 2.
3. Now place focus in Google toolbar search field and press Tab
4. Instead of focus being placed in Field 1 nothing happens until you press Tab again.

* RESULTS
Focus should be placed in field after pressing Tab key. However, focus fails to be place in input field until you press Tab key a second time.

* REGRESSION
Yes, this only occurs with TOT Webkit.
Comment 1 Chris Petersen 2006-04-04 10:07:00 PDT
Created attachment 7502 [details]
Input test
Comment 2 Chris Petersen 2006-04-04 10:10:36 PDT
This issue has been filed as <rdar://problem/4501430>
Comment 3 Adele Peterson 2006-04-21 22:42:01 PDT
Created attachment 7891 [details]
patch
Comment 4 Darin Adler 2006-04-21 22:47:33 PDT
Comment on attachment 7891 [details]
patch

Looks like a good fix to me. r=me