Bug 81776 - Web Inspector: HeapProfiler: DOM node id can overflow Int32.
Summary: Web Inspector: HeapProfiler: DOM node id can overflow Int32.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Ilya Tikhonovsky
URL:
Keywords:
Depends on:
Blocks: 78411
  Show dependency treegraph
 
Reported: 2012-03-21 06:45 PDT by Ilya Tikhonovsky
Modified: 2012-03-21 07:33 PDT (History)
10 users (show)

See Also:


Attachments
Patch (4.09 KB, patch)
2012-03-21 07:07 PDT, Ilya Tikhonovsky
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Tikhonovsky 2012-03-21 06:45:28 PDT
Patch to follow.
Comment 1 Ilya Tikhonovsky 2012-03-21 07:07:49 PDT
Created attachment 133037 [details]
Patch
Comment 2 Pavel Feldman 2012-03-21 07:18:02 PDT
Comment on attachment 133037 [details]
Patch

This seems like a temporary measure. Is there a long term plan for even greater values?
Comment 3 Ilya Tikhonovsky 2012-03-21 07:22:07 PDT
Committed r111540: <http://trac.webkit.org/changeset/111540>
Comment 4 Ilya Tikhonovsky 2012-03-21 07:33:57 PDT
(In reply to comment #2)
> (From update of attachment 133037 [details])
> This seems like a temporary measure. Is there a long term plan for even greater values?

The node id has uint type at the backend. Thus it can't overflow uint by design.