Bug 8173 - Win32 build is broken due to not handling spaces in pathnames
: Win32 build is broken due to not handling spaces in pathnames
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 420+
: PC Windows XP
: P2 Normal
Assigned To: Eric Seidel
: Regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 04:04 PDT by Eric Seidel
Modified: 2006-04-04 04:46 PDT (History)
3 users (show)

See Also:


Attachments
Workaround (1.38 KB, patch)
2006-04-04 04:26 PDT, Eric Seidel
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel 2006-04-04 04:04:11 PDT
Win32 is broken for all of us poor schmucks who happen to have spaces in the path to our SRCROOT.

I think this may be due to:
http://savannah.gnu.org/bugs/?func=detailitem&item_id=712

I've tried quoting the individual args of the VPATH as well as quoting all variable uses in the Makefile.  I don't seem to get past the VPATH check, as I always get:

(extra logging enabled)

Performing Pre-Build Event...
sw_vers: Command not found.
Webcore = /cygdrive/c/Documents and Settings/Eric Seidel/Desktop/WebKit/WebCore
make: Entering directory `/cygdrive/c/Documents and Settings/Eric Seidel/Desktop/WebKit/WebCore/DerivedSources/WebCore'
make: *** No rule to make target `css/CSSGrammar.y', needed by `CSSGrammar.cpp'.  Stop.
make: Leaving directory `/cygdrive/c/Documents and Settings/Eric Seidel/Desktop/WebKit/WebCore/DerivedSources/WebCore'
Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."
Comment 1 Eric Seidel 2006-04-04 04:06:49 PDT
In fact, this limitation seems to be documented in the Make readme:

http://cvs.savannah.nongnu.org/viewcvs/make/make/README.W32.template?rev=2.11

search for "white space"
Comment 2 Eric Seidel 2006-04-04 04:26:37 PDT
Created attachment 7499 [details]
Workaround

I think I'm almost disappointed this was so "easy" to workaround.  I think I would have enjoyed ranting about make bugs w/ darin come morning. :)
Comment 3 Anders Carlsson 2006-04-04 04:43:54 PDT
Comment on attachment 7499 [details]
Workaround

r=me