Bug 81518 - HTML5 audio elements always display "Loading..." when preload set to none
Summary: HTML5 audio elements always display "Loading..." when preload set to none
Status: RESOLVED DUPLICATE of bug 44010
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-19 09:22 PDT by Adam Drew
Modified: 2012-03-20 10:46 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Drew 2012-03-19 09:22:41 PDT
Description:
Webkit (and thus Safari) always display "Loading..." in the audio controls when using HTML5 <audio> tags and preload is set to none. On Webkit and Safari the controls will display "Loading..." forever even though nothing is loading. On Chrome, Firefox, Internet Explorer, and Mobile Safari on iOS the controls are displayed with no "Loading..." message. On Safari and the Webkit nightly however it always displays "Loading..."

Tested on:
Safari Version 5.1.4 (7534.54.16)
Webkit r111148 19 March 2012

Observed behavior:
"Loading..." displayed forever on audio controls when using preload="none"

Expected behavior:
No "Loading..." message when preload="none"

How Reproducible:
100%, just use some code like this:

<audio preload="none" autobuffer="" controls type="audio/mp3" src="somesong.mp3"/>

Reproducer:
http://linkedlistcorruption.com/music/test.html
Comment 1 Eric Carlson 2012-03-20 10:46:20 PDT

*** This bug has been marked as a duplicate of bug 44010 ***