Bug 8141 - REGRESSION: Native text field fails to wrap inside table
Summary: REGRESSION: Native text field fails to wrap inside table
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL: http://www.midwestairlines.com/MAWeb/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2006-04-02 14:26 PDT by Chris Petersen
Modified: 2006-04-07 15:31 PDT (History)
0 users

See Also:


Attachments
screen shot of issue using latest webkit (5.50 KB, image/png)
2006-04-02 14:29 PDT, Chris Petersen
no flags Details
reduced test case (490 bytes, text/html)
2006-04-02 14:30 PDT, Chris Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2006-04-02 14:26:27 PDT
I spotted a issue at http://www.midwestairlines.com/MAWeb/ when the native input filed wasn't rendered underneath the User ID text.

I have reduced this issue to a table that contains text and <input=text>. The table has a specified width of "35" pixels and the input element has style="width: 30px;" applied .

The input is inline with some text so I was expecting it to wrap to second line based on the width of the table. Instead , the table appears much wider than expected. This seems to be caused by the native text field even though it's border isn't this wide. See screen shot.

I included a DIV element with the same setting as the table as a comparsion. The input element and text in DIV wrap correctly as expected.
Comment 1 Chris Petersen 2006-04-02 14:29:04 PDT
Created attachment 7467 [details]
screen shot of issue using latest webkit
Comment 2 Chris Petersen 2006-04-02 14:30:29 PDT
Created attachment 7468 [details]
reduced test case
Comment 3 Chris Petersen 2006-04-02 14:36:04 PDT
Steps to reproduce:

1) With TOT Webkit, open the attached test case "midwest_2.html"
2) Notice the difference between the table and div. The text field (dashed border) in the table should wrap down to the next line but doesn't. This is a gap between the right side of the text field and right border of the table.
Comment 4 Chris Petersen 2006-04-02 14:51:11 PDT
This is filed as <rdar://problem/4499274>
Comment 5 Maciej Stachowiak 2006-04-02 23:25:45 PDT
These are all text field regressions so they should all be P1.
Comment 6 Adele Peterson 2006-04-03 18:27:40 PDT
I'm working on fixing calcMinMaxWidth, which will fix this bug.
Comment 7 Darin Adler 2006-04-03 21:11:38 PDT
Assigning to Adele, since she's working on it.
Comment 8 Chris Petersen 2006-04-07 15:31:03 PDT
Verified as fixed with latest TOT Webkit (04/09/2006)
Comment 9 Chris Petersen 2006-04-07 15:31:26 PDT
Verified as fixed with latest TOT Webkit (04/07/2006)
Comment 10 Chris Petersen 2006-04-07 15:31:53 PDT
Closing.