Bug 8123 - focus outline on new text field doesn't look like the old one
Summary: focus outline on new text field doesn't look like the old one
Status: RESOLVED DUPLICATE of bug 8093
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Darin Adler
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-04-01 13:18 PST by Darin Adler
Modified: 2006-04-03 15:16 PDT (History)
2 users (show)

See Also:


Attachments
patch with detailed change log (10.42 KB, patch)
2006-04-01 13:30 PST, Darin Adler
no flags Details | Formatted Diff | Diff
patch with detailed change log -- also deals with blue/graphite appearance (65.16 KB, patch)
2006-04-01 22:13 PST, Darin Adler
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2006-04-01 13:18:36 PST
We need to change the new text field so the outline is exactly like the old one.
Comment 1 Darin Adler 2006-04-01 13:30:19 PST
Created attachment 7445 [details]
patch with detailed change log
Comment 2 Darin Adler 2006-04-01 22:13:04 PST
Created attachment 7455 [details]
patch with detailed change log -- also deals with blue/graphite appearance
Comment 3 Adele Peterson 2006-04-02 12:12:50 PDT
Comment on attachment 7455 [details]
patch with detailed change log -- also deals with blue/graphite appearance

r=me, assuming you talk to Hyatt about the strict mode issue at some point :)
Comment 4 Eric Seidel (no email) 2006-04-02 16:13:25 PDT
Has this landed?

Something recently caused the pixel tests to regress wrt focus rings:
http://build.webkit.org/results/post-commit-pixel-powerpc-mac-os-x/128/
Comment 5 Darin Adler 2006-04-02 17:54:10 PDT
(In reply to comment #4)
> Has this landed?

No, but I'm landing it right now, along with new pixel test results.

> Something recently caused the pixel tests to regress wrt focus rings:
> http://build.webkit.org/results/post-commit-pixel-powerpc-mac-os-x/128/

That was the WebKitSystemInterface change, which was a precursor to this one. I knew it would change the appearance of focus rings; sorry, I forgot to mention that to you.
Comment 6 Dave Hyatt 2006-04-02 23:13:51 PDT
outline-offset is an actual CSS property.  By changing it to accept negative values, we now violate the spec.  We need to log this as an issue in our bug database so that we can lobby to get the spec changed.  If not, we will have to change outline-offset to -khtml-outline-offset before shipping.

Comment 7 Maciej Stachowiak 2006-04-02 23:50:47 PDT
In Radar as <rdar://problem/4497131>
Comment 8 Dave Hyatt 2006-04-03 00:07:27 PDT
Actually nvm.  It looks like the restriction does not exist any more in the current spec.
Comment 9 Darin Adler 2006-04-03 15:16:31 PDT

*** This bug has been marked as a duplicate of 8093 ***