Bug 8118 - REGRESSION (r13595): Inline block's clipped overflow increases table row height
Summary: REGRESSION (r13595): Inline block's clipped overflow increases table row height
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2006-03-31 23:54 PST by mitz
Modified: 2006-04-04 01:53 PDT (History)
0 users

See Also:


Attachments
Test case (370 bytes, text/html)
2006-04-01 00:00 PST, mitz
no flags Details
Patch including layout test and change log (5.88 KB, patch)
2006-04-01 00:31 PST, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-03-31 23:54:17 PST
An inline block with clipped overflow makes the line's vertical overflow increase to accommodate its overflow as if it isn't clipped. This becomes evident when the line is inside a table cell, since cells grow to include overflow.

I'm going to attach a test case and a fix soon.
Comment 1 mitz 2006-04-01 00:00:16 PST
Created attachment 7433 [details]
Test case
Comment 2 mitz 2006-04-01 00:31:06 PST
Created attachment 7435 [details]
Patch including layout test and change log
Comment 3 Darin Adler 2006-04-01 01:14:08 PST
Comment on attachment 7435 [details]
Patch including layout test and change log

r=me
Comment 4 mitz 2006-04-04 01:53:23 PDT
Verified in r13675 nightly.