Bug 81044 - Support loading a WKPage from web archive data
Summary: Support loading a WKPage from web archive data
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jeff Miller
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 15:32 PDT by Jeff Miller
Modified: 2012-03-13 21:04 PDT (History)
6 users (show)

See Also:


Attachments
Patch (6.31 KB, patch)
2012-03-13 15:37 PDT, Jeff Miller
no flags Details | Formatted Diff | Diff
Patch (6.25 KB, patch)
2012-03-13 16:35 PDT, Jeff Miller
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Miller 2012-03-13 15:32:28 PDT
Support loading a WKPage from web archive data
Comment 1 Jeff Miller 2012-03-13 15:37:50 PDT
Created attachment 131730 [details]
Patch
Comment 2 Brady Eidson 2012-03-13 15:42:39 PDT
Comment on attachment 131730 [details]
Patch

I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"
Comment 3 Jeff Miller 2012-03-13 15:44:55 PDT
(In reply to comment #2)
> (From update of attachment 131730 [details])
> I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"

Sounds reasonable. New patch soon.
Comment 4 Jessie Berlin 2012-03-13 15:45:34 PDT
> (From update of attachment 131730 [details])
> I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"

I think that naming came from Sam and Anders (loadWebArchiveFromData). It might have been "ForData".
Comment 5 Jeff Miller 2012-03-13 15:47:35 PDT
(In reply to comment #4)
> > (From update of attachment 131730 [details] [details])
> > I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"
> 
> I think that naming came from Sam and Anders (loadWebArchiveFromData). It might have been "ForData".

OK. I eagerly await their opinions.
Comment 6 Brady Eidson 2012-03-13 15:49:18 PDT
(In reply to comment #4)
> > (From update of attachment 131730 [details] [details])
> > I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"
> 
> I think that naming came from Sam and Anders (loadWebArchiveFromData). It might have been "ForData".

I'm suggesting "WKLoadWebArchiveData"
I don't think the current "WKLoadWebArchiveFromData" flows very well or follows naming precedent.
I think "WKLoadWebArchiveForData" doesn't make any sense at all!
Comment 7 mitz 2012-03-13 16:24:12 PDT
(In reply to comment #6)
> (In reply to comment #4)
> > > (From update of attachment 131730 [details] [details] [details])
> > > I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"
> > 
> > I think that naming came from Sam and Anders (loadWebArchiveFromData). It might have been "ForData".
> 
> I'm suggesting "WKLoadWebArchiveData"

I think you mean WK*Page*LoadWebArchiveData.
Comment 8 Jeff Miller 2012-03-13 16:35:33 PDT
Created attachment 131749 [details]
Patch
Comment 9 Jeff Miller 2012-03-13 16:36:07 PDT
I agree with Brady, I've attached a new patch.
Comment 10 Brady Eidson 2012-03-13 16:37:26 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #4)
> > > > (From update of attachment 131730 [details] [details] [details] [details])
> > > > I'd rather see every instance of "WebArchiveFromData" be "WebArchiveData"
> > > 
> > > I think that naming came from Sam and Anders (loadWebArchiveFromData). It might have been "ForData".
> > 
> > I'm suggesting "WKLoadWebArchiveData"
> 
> I think you mean WK*Page*LoadWebArchiveData.

Yes, sure did.
Comment 11 Jeff Miller 2012-03-13 16:39:22 PDT
Committed r110638: <http://trac.webkit.org/changeset/110638>
Comment 12 Sam Weinig 2012-03-13 18:28:22 PDT
This patch is missing API tests.  Please add them.
Comment 13 Jeff Miller 2012-03-13 21:04:26 PDT
(In reply to comment #12)
> This patch is missing API tests.  Please add them.

I wrote up bug 81073 to track this.