Bug 8085 - REGRESSION: Main menu positioned incorrectly on eia.org and fedex.com/us
Summary: REGRESSION: Main menu positioned incorrectly on eia.org and fedex.com/us
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.eia.org/
Keywords: NeedsReduction, Regression
: 8151 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-30 09:48 PST by mitz
Modified: 2006-04-04 01:56 PDT (History)
2 users (show)

See Also:


Attachments
Fix table cells' offsetTop (4.09 KB, patch)
2006-04-03 13:01 PDT, mitz
bdakin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-03-30 09:48:47 PST
The green menu bar on eia.org should be at the top, right below the blue site head. In TOT it appears in the middle of the page.
Comment 1 mitz 2006-04-01 10:40:18 PST
This bug seems to be caused at least in part by offsetTop() returning the wrong offset, for the same underlying reason as bug 8081. I tried skipping table rows in RenderObject::offsetTop() but it didn't fix the bug completely, only moved the menu up.
Comment 2 mitz 2006-04-02 09:00:49 PDT
This bug is seen also in http://fedex.com/us/ . I also noticed that the EIA site behaves differently when I set the user agent to Netscape 7 (still off, but not by as much), so maybe they have Safari-specific code to work around the old behavior where table rows' offsetTop was 0, and the fix for this bug is really not to add table rows in RenderObject::offsetTop().
Comment 3 mitz 2006-04-03 08:44:52 PDT
*** Bug 8151 has been marked as a duplicate of this bug. ***
Comment 4 mitz 2006-04-03 13:01:53 PDT
Created attachment 7489 [details]
Fix table cells' offsetTop

This patch fixes fedex.com and the site mentioned in bug 8151 but not eia.org. I think the latter either has Safari-specific code to accommodate the old behavior (of rows' offsetTop being 0) or there's a different bug affecting it.

fast/dom seems like the wrong place for the layout test. Feel free to relocate it when-if landing.